Unfortunately, the current implementation is not very helpful.
For example, it would be more meaningful if, when creating a sales order, an automatic check would take place for a possible exceeding of the credit limit.
So that at that moment it can be decided whether delivery should take place, despite the fact that the delivery (sale) is not covered by the credit insurance company.
Indeed, different names would avoid confusion. In my humble opinion, the name in the customers’ listing is incorrect.
Although the name is not necessarily wrong, in the context of credit insurance perhaps a simple [Credit Limit] would be better.