Custom report from Receipts& Payments has no amount column

Hello, when I am trying to create a custom report from “Receipts& Payments”, then in “Select…”.
when I want to select the column of Amount or Debit or Credit I can’t find it.
please include to the list of the columns the column of the amount or it is better to make it Debit and Credit.
thank you.

You are taking the wrong approach. When creating reports where you select Receipts & Payments as the From… source, you can only generate reports about the transactions themselves, not reports about amounts posted to accounts. For that, you must select General Ledger Transactions in the From… field.

See Example 2 in the Guide: https://www.manager.io/guides/18075.

O.k you are right.
But i added custom column called (cheque No.) to Receipts & payments tab.
Hence, when i create report generated from General Ledger Transactions i will get a report without my custom field (cheque No.).
Plus, what is point of a report without the amount of each transaction???
thanks for your reply.

True. But that is because amounts, debits, and credits are associated with line items. Your custom field is associated only with the form itself. So you can get information about the receipt or payment form or information about the transactions posted to the general ledger, but not both. To do that, you can copy the Receipts & Payments listing to the clipboard, paste into a spreadsheet, and manipulate as necessary.

The point is to allow users to extract information from the database. Just because you don’t want something doesn’t mean others might not. Satisfying everyone with a built-in report is an impossible task. So the program provides:

  • Built-in reports for the the most common financial reports
  • Export capability so you can manipulate data on your own
  • Custom reports for other needs

None of those options covers everything. They are complementary, not duplicative.