Custom field in Business Details not showing

@lubos
19.5.65 Windows 10 x64

  1. the business identifier when created as a custom field do not show on any documents. neither the old records nor newly created records.
    the custom field has been set to show on printed documents.

  2. what was the necessity to remove this unique field? you could have just provided a checkbox to enable the field and enter the details rather than removing the field itself. having the unique variable for business identifier was very helpful in custom themes as we could easily set them to show on reports where having the whole address was not needed. please understand that a business identifier is not a part of business address because a business can operate from multiple locations with the same business identifier. making it a part of business address will not help users who are not skilled in customizing a theme.

this was an unnecessary change in my personal opinion. users are requesting a unique field to record business identifier for suppliers and Manager has removed the option for having the same for our own business.

1 Like

For sure @lubos should enable showing custom fields on the themes. However this change was made necessary by the new requirements that are becoming compulsory by the new laws around the world that are making invoices and taxes reporting digital. For example in Italy as business identifier we have:

  • Partita IVA
  • Codice Fiscale
  • Numero REA
  • Codice Univoco FA

@Davide if what you explained where the reasons, then this could have been implemented as country specific options by @lubos

That’s exactly why he enabled custom fields here…

yes true. but it does not appear on printed documents.
is it a bug which would be fixed?
or is there any plans to change how business identifiers are handled?

until i get a response from @lubos i am not sure if i should wait or start modifying custom themes.

having the business identifier as a part of business address is not practical for us since we operate from different locations. so the reports we generate fr customers and suppliers need only the company name and business identifier. a unique field or as the case is now, a custom field would enable us to place the business identifier on reports and transactions at a desired place.

I can reproduce this. I have moved posts related to this issue to this new topic for visibility and placed it in the bugs category.

I understand that custom fields were added to Business Details to facilitate country-specific reports, and that the old Business identifier field is no longer considered standard. But all custom fields should behave the same way. That is, if the box is checked to show on printed documents, the field should show up, regardless of why it is being added.

2 Likes

@lubos can you please prioritize fixing this issue? temporarily i have placed it along with the business address for invoices as this is a legal requirement to show business identifier on documents. but all the reports are on hold and its already the month end.

2 Likes

Please @lubos expose business details custom fields into the themes

1 Like

@lubos any updates on this?

Using 19.6.41 on Win10-64bit.

On the same boat here: I have created a few custom fields for “Business Details” section and checked the “printable” option but there’s no way to access them from theme file. I need to put some of this business info in the footer of each document, as per legal requirements in our country.

Can someone please help with this? @lubos Please enlighten us, bro.

Thanks!

Fixed in the latest version (19.6.50)

If you are using custom theme, you probably have a line in there like:

<div>{{ business.identifier }}</div>

If you want custom fields defined on business details screen to be shown, you will have to replace that line for something like this:

{% for field in business.custom_fields %}
<div>{{ field.label }} {{ field.text }}</div>
{% endfor %}

But this is only for custom themes. In-built themes have been updated automatically.

5 Likes

Thank you @lubos . works perfect.

@lubos, thank you very much. Super quick turnaround.