Creating purchase invoice form sales quote problem

When creating purchase invoice from sales quote by the copy to button prices in purchase invoice are retail not trade price.

I am having to re-enter all the part numbers again to get the trade prices.

Yeah, I can see that your suppliers will charge you less than you would charge your customers.

So rather than prices being copied straight from sales quote, you need those prices to be taken from inventory items purchase price field right?

Yes that’s right.
It seems to select the correct account ‘Inventory on hand’ but prices just need to be purchase price as you said.

Thank you.

Any update on this matter? I also use the same steps, and it would save a lot of time if the prices on the newly created P/O would be taken from the purchase price of the inventory items.

As a further suggestion:
When you are developing the RFQ (multiple suppliers), it would be nice to be able to copy from Sales Order to create a new RFQ, but WITHOUT any prices being pulled in.

Any idea when this may be addressed?

I’ve added this to the latest version (15.0.57)

I must be missing something here. I just upgraded to 15.0.58 (Ubuntu 14.04).
Then created a new Sales Quote.
Used “Copy to… New Purchase Order”.
It still pulls in the selling price, not the purchase price, as indicated on the Inventory.

Screenshot of item in inventory:

…and the Sales Quote:

…and the resulting P/O:

Am I missing something?

It seems intermittent.
i just tried it 3 times and it worked once.
I found if it was correct then clicked back it would change the quote price to purchase price.

I only did this for Sales quote -> Purchase invoice.

The latest version (15.0.60) does it also on Sales quote -> Purchase order which is what you were testing for.

I tried both, sales quote -> purchase invoice & sales quote -> purchase order.

It seems if you create sales quote then copy to purchase invoice it has the correct purchase cost but if you don’t click create/save and click back it goes back to the sales quote but the price is now purchase price instead of sales price.

It seemed intermittent though.

@itmoto, I’m able to reproduce this issue. I fixed this bug in new version 15.0.62

Thanks Lubos.
I will give it another go tomorrow and let you know how it goes.

Works perfectly.
Thank you!

Hi @lubos, I am using version 16.5.85 and am finding when copying to New Purchase Invoice from Sales Quote, the prices are retail not cost.