Concept BTW Aangifte report

You need to enter data with the new tax codes

Hi guys,

I’m testing this in a test-company and it is indeed clickable when data is entered with the new tax-codes.
Today I’m going to send my final test-results to Lubos with a backup of my testcompany so that he can check what I tested and can see the results.

Kind regards,


Any news on this topic? I’ve put all updates on hold since v20.8.67 'cos it’s nearly the end of the 3rd quarter.

@Mark, it was always safe to upgrade. Anyway, the current version makes Concept BTW Aangifte report clickable so you can drill-down into any figure.

OK. Thanks for your quick reply @lubos What about the customised BTW Aangifte report (2) I created in report transformation (as line 55 should end with ‘floor %}’ and line 56 with ‘ceil % }’)? Can you confirm that customised report will be kept after updating, or did you already modify those lines?

BTW, a big thanks for the amazing work you’ve done with this excellent program. :+1:t2:

Even though report transformations are exposed in the program, they are not meant to be created by end-users. Usually you’d import reports we create.

Why did you have need to create custom report transformation?

As I wrote and already mentioned a few times:

BTW, I did import the BTW Aangifte report a long time ago and I simply created a new report by copying its code but modified the mentioned lines.

I was thinking about it and decided not to do any rounding on country-specific reports even if tax authority does require amounts to be rounded.

The reason is that figures are pulled from general ledger and you can click on each figure in country-specific report which will reveal individual transactions and how they make up the balance. And I want the figure on the report to match with the total of those transactions when drilling-down.

That’s OK with me 'cos knowing that it’s allowed for the tax payers to round in their advantadge, users can see and apply the rounding on the amounts themselves.

The question that remains to be answered is whether an update deletes my created report or not.

If you have created report transformation from scratch, then the update will basically break your report (it won’t work) because new report transformations are using different programming concept.

I really don’t recommend making custom report transformations. Let us create them, maintain them and use ours which are officially supported.

Here is the screenshot how new Concept BTW Aangifte report is done. It’s very different.

For example, to apply ceil or floor filter, you would have to replace hyperlink filter with balance | ceil or balance | floor but then you lose drill-down functionality. I think drilling-down is more valuable than rounding.

@Lubos has asked me to check a new version of the Concept BTW Aangifte which is per today downloadable. I have tested it in a newly opened testcompany and all Vat codes work fine and all figures are presented on the proper lines. All figures are clickable so you can drill down if you like. You can also make for instance a year-end journalentry where you can make a corrections for for example private usage of telephone costs. In the past these Vat corrections were shown as a sales transacties, but now if you choose the supplier this correction it is booked as a negative value in the purchase Vat. There are two things left to correct. When you sell an asset, you can’t choose the fixed assets g/l account. Two reports specifying sales and purchases with tax codes do not report credit and debitnotes. So a few teethingproblems left but it is a big improvement compared to what is was.

I think I somehow messed up. When importing Tax codes I get:

In [Settings] the “old” tax codes are also shown:

No need to tell that figures in the Summary are not in sync with the figures in the new report [Concept BTW Aangifte].

How to correct? Make use of batch update? Or correct invoices containing [BTW 21% Inkoop] and [BTW 9% Inkoop] by hand?

Backup your business then I would use Find and recode bank transactions to

  • find the old tax code
  • replace it with the new tax code

Yes. Do not use these 2 tax codes. Recategorize transactions in those tax codes to BTW 21% and BTW 9%

Then look into your Tax Codes list and you can delete all tax codes except for BTW 21% and BTW 9% which are the only ones you are using.

Also, currently Manager insists all Dutch tax codes are imported but I’m planning to make it selectable so only a few are checked by default and others you can import only if needed in your business. For example, you seem to be using only 2 tax codes.

Works OK for me

The method will not work for invoices or journal entries though

1 Like

Sorry to disagree. If I had to choose between having the rounded amounts ready to file the VAT declaration and the new drilling-down feature, I would choose the rounded amounts as the drilling-down feature is already present in all the entries in the Tax Codes section.

Reading the comments I’m going to postpone updating the program until october.

@lubos followed your instructions. Made corrections by hand. (Took some time, but this way I avoided making mistakes/troubles by using batch update). Set unnecessary vat codes to [inactive].

Assigned one account named [Te betalen - te vorderen BTW] (VAT to pay - to claim) to tax codes used. (21%, 9%, 6%).

Figures in Summary and Reports and [Concept BTW Aangifte] are all in line now.

Thank you for the quick response!

Well, I certainly feel foolish. I’ve never used Find & Recode on a real business. It seems every test of the function I’ve ever done was on a business with no tax codes, where the field doesn’t appear. I will delete my erroneous post. Thanks for educating me.

Why can’t I see the Concept BTW Report (New) with the new tax codes when trying to import the tax codes? Desktopversion 20.9.57, language Dutch. Am I missing something?

There is no [New] anymore. I have a Cloud version 20.9.71. This what I get when importing tax codes: