Concept BTW Aangifte report error

I’m sorry to report an error in the Concept BTW aangifte report:

  • When using Billed Expenses with tax code BTW 21% non-EU for a purchase of a Zoom fee, the automatic reversal posting created when invoiced ends up in 3a Leveringen naar landen buiten de EU (uitvoer). That is incorrect. 3 Prestaties naar of in het buitenland is being used for sales tax only. It should have been reported in 4a Leveringen/diensten uit landen buiten de EU.

  • The original purchase invoice tax of the Zoom fee is reported in category 5b voorbelasting (correctly), but with a negative amount (incorrect).

  • I expect this problem to occur with the BTW 21% EU and the 9% EU/non-EU as well.

@Tut and @Lubos
What Into TheMirror reported is indeed correct and it is a bug. It happens with both 9 and 21% EU
You also have to check the two non-EU codes as well. Both are not reported at the correct place on the BTW-form.
When I tested the new Concept BTW Aangifte I didn’t test Billable Expenses. Sorry for this omission.

I moved this reported malfunction and confirmation to a separate topic and placed it into the bugs category. The topic where it was originally posted covered too many other things for this to receive proper attention.

In addition, the VAT report is printing decimals as well and it should be rounded figures. and when fixing the bug please include the related bug as well:

Please don’t forget to include creditnotes and debitnotes in the report Taxable sales per customer and Taxable purchases per supplier and to make Fixed Assets selectable when creating a salesinvoice for the sale of an asset. This makes it 100% perfect.

In Concept BTW Aangifte report - #28 by lubos @lubos indicated:

Actually this is an interesting edge-case because billable expense transactions can be associated with a customer and supplier at the same time (I forgot about that). And currently if this is the case, Manager will consider this transaction as a sale which is wrong. It should be a purchase.

Could you test in the latest version (20.10.44) whether this transaction correctly flows into tax reports?

It’s a payment to Supplier named “Zoom” for a billable expense allocated to Customer called “Client”.

I will get this result:

Hi Lubos,
I checked the billable expense with the EU and non-EU VAT codes. It works fine now.
That brings me to what has not been reported as a bug, but which it is: creditnotes and debitnotes are not included in the reports:Taxable sales per Customer and Taxable Purchases per Supplier. This is essential information for proper tax reporting/filing. October is VAT tax-reporting month in the Netherlands. Would you please be so kind to fix this.
Last but not least: make Fixed Assets selectable when creating a sales invoice.
Kind regards and thanks in advance.

@Hennie both issues fixed in the latest version (20.10.72)


Thank you very much.

I am experiencing the same problem, as @Hennie

VAT report is printing decimals as well and it should be rounded figures.

Working with version 21.1.53, and also re-imported the localization (Settings > Import > Concept BTW Aangifte)

I hope somebody can help me out.

Thank you

You’ll find the answer of Manager’s developer in post #4 above.

The developper has given a very good reason why figures are not rounded so you have to live with that.phenomenon. Take care that after importing a new initialization file, you check in settings, the individual tax codes on the proper VAT liability account setting.

At the very first, thank you for the quick responses.

The reason sounds logical and valid, so from now on I will have to round figures from the report when doing VAT declaration

I noticed that the already last year generated reports in Manager also changed and doesn’t match anymore with exported to PDF’s from Manager at that time.

Do I have to make some changes in the TAX-codes from now on? These changes are also effective on everything from last year. See also the printscreen below

Thanks in advance.

When you click on “Bewerken” = “Edit” you can check the setting for the VAT liability account.