Cannot delete but can zero bank account transactions

I found such things as duplicate entries and simply erroneous entry that should not have been entered in a bank account. I click delete but nothing happens. Seems I can update most anything about the transaction. I can change the account, date, payee, and amount.

The closest I can get to deleting such entries is to blank the fields and zero the amount. This updates. So now I have blank, zero entries that I cannot delete.

Does this happen when I import transactions? Does not seem like it is by design because there is a delete button. Just that the delete button does not delete.

I saw from another post that you cannot delete an entry used someplace else. I don’t have invoices. These are just entries in a bank account. I don’t know where they could be used. I don’t have a Lock Date set.

I suppose what I want to know is whether I am supposed to be able to delete transactions in bank accounts or is zeroing the transactions the closest I can get to deleting?

You should be able to delete bank transactions by clicking the Delete button. What edition (desktop, server, or cloud) and version number are you using?

I’m using cloud edition.

I went into batch delete to see whether I could delete from there:

I went to Bank Accounts >> Capital One Credit Card [a credit card bank account I set up] >> Batch Delete [at bottom]

In the search box I typed 0.00 to find transactions that I zeroed. I clicked Search. The result was Empty.

Then I clicked Undo. The result was a page with the following:

Internal Error

18.3.17 (Cloud)


System.InvalidOperationException: Nullable object must have a value.
at System.Nullable`1.get_Value()
at ManagerServer.HttpHandlers.Businesses.Business.BankAccounts.BankTransactionsBatchDelete.Get()
at HttpFramework.HttpApplication.ProcessRequest(HttpRequest request, HttpResponse response)
at ManagerServer.HttpApplication.ProcessRequest(HttpRequest request, HttpResponse response)

Maybe the information shows I am using Cloud version number 18.3.17.

Maybe there is some problem when I search for 0.00. 0.00 is taken as a null value which does not match my zero amount entries? So, I get empty results from the search. Or could be many other things, I suppose. Probably not normal to search for 0.00.

Anyway, I see the internal error as unrelated to my not being able to delete.

The transaction I’m trying to delete has a date of 3/10/2017. I don’t have any date lock. Is there a limit how far back I can delete a transaction?

I was able to delete a transaction using bulk delete.

In batch delete, I could not search on the amount, happened to be 179.99. Came up empty. But I was able to search on part of the description. I found 179.99 entered twice. I checked one of them. I deleted. Then I went back to find it. I searched for 179.99 and saw it was only entered once.

When I had tried to delete it by clicking edit, then delete, it did not delete. But I was able to delete it in batch delete.

Cloud edition is always up to date. So that isn’t causing any problem.

The Search function does not search the Amount column while doing Batch Delete. I’m not sure why.

This seems like a possible bug. I also encountered strange, though different, behavior when testing. I will write a bug report.


I recommend you do nothing further with Batch Delete. We need to figure out why you could not perform a normal deletion.

I found that the error page has nothing to do with what I search on. It’s not because I searched on 0.00.

I get the error page just by clicking on undo, to undo the search.

Also, it’s not just 0.00 that turns up empty even though there are transactions of amount 0.00. Seems that search in batch delete does not include amounts, regardless of the amount. In batch delete, I can search on part of the description to find the transaction I want to delete.

That is what I told you.

I don’t remember when you told me that search in batch delete does not include amounts. Maybe you told me a year ago?

But I guess everything works out okay because even though the delete transaction button does not work for me, I can delete by using batch delete. Maybe safer this way.

I told you 27 minutes ago in post #5 of this topic.

Definitely not safer. The potential exists for irrecoverable mistakes whenever you use Batch Delete. One accidental click in the top checkbox and you could wipe out all records for a bank account. Batch Delete is a very dangerous operation.

I want to get to the bottom of your problem. If you have a test company, can you enter a dummy bank transaction and then try to delete it? Or can you make a dummy entry in one of your real bank accounts and immediately delete it? If you can, but you could not delete an earlier transaction, there was something wrong with that transaction. If you cannot delete a new transaction, there is something wrong with the program.

Now I see where you told me about batch search.

Now this starts to look like a browser problem. I made a test business called Test. Then I changed my mind and decided to make the dummy entry into a real bank account. So, I tried to delete Test business and it would not delete. All this is in FireFox browser.

I brought Manager up in Chrome browser. No problem deleting Test business in Chrome browser.

I’m going to do the dummy entry in a real bank account in FireFox browser. If it doesn’t work, then I’ll try it in Chrome. I’ll let you know what I find. Might be that there is something different between the two browsers for the “are you sure” alert windows. But I’ll let you know.

That seems to be the difference: Chrome and Firefox browsers.

In Firefox, I created a new dummy transaction in a real bank account. I then clicked edit to go in to delete the dummy transaction. I clicked on Delete button, the popup (or alert) window opened asking if I am sure. I clicked OK. Nothing happened.

I brought up Manager in Chrome. I found the dummy transaction. Clicked edit. Clicked delete. The alert window asked if I am sure. I clicked OK. the Transaction deleted. I went back to Firefox. I saw the dummy transaction is gone, deleted.

I use Chrome until I have some problem with Chrome. Then I switch to Firefox until I have some problem with Firefox. Then I check Edge whether it will install the plugins I like to use that force-allow paste and that stop surreptitious tracking. So far always comes out that Edge still won’t install the plugins. So, I switch back to Chrome, and the cycle begins again.

Which browsers do you like, in general?

I tried going into Batch Delete using Chrome Browser. I search for whatever. The I click on undo. I still get the error page. So, that error page comes up for me in both Firefox and Chrome.

I use the desktop edition.

I entered a bug report.