Billable expenses - delete rogue entry

Hi All,

EDIT: Should say, using 19.7.41 on Win7

I’ve been using manager for a month or so now for my new business, and it’s fantastic! This is the first time that I’m properly stuck, it may be a bug but I’m not sure.

I was entering expense claims and invoices against a job. I entered/deleted things several times in various combinations while I was testing how I wanted to do it, and it looks like somehow I’ve ended up with a rogue loose transaction still included that I can’t delete.

On my summary page there is a billable expenses balance outstanding (which there shouldn’t be, because the invoices have been paid), and when I click on the blue text to see how it’s calculated I see this (viewing in batch delete mode, the delete option for the row is greyed out):

It is debited, but there is no corresponding transaction remaining in ‘expense claims’ where the “real ones” are entered - only the two I expect which have been paid off by the invoice.

How do I get rid of this entry?

Could it be linked to other recent issues with billable expenses? - Billable Expense Misbaviour

Thanks for any help!
Kevin

You have raised a couple of misconceptions in this statement:

  • You did not get to the Batch Delete page just by clicking on the blue balance for Billable expenses on the Summary page. You can only reach the page you are showing by further action. You had to also click the Batch Delete button while viewing the list that actually did appear. And there is no reason for you to have done that in this situation. You should not expect billable expenses to disappear from the drill-down list just because they have been either invoiced or paid. If they were valid transactions, they will remain in the list as contributors to the balance.
  • The balance of Billable expenses does not depend on whether a customer has paid for the expenses. That balance is reduced to zero only when all billable expenses have been transferred to Accounts receivable through invoicing. It can remain zero even if the customers never pay what they owe from sales invoices.
  • If you ever do go into the Batch Delete mode the way you did, you will never be able to delete sales invoices, because you are not in the Sales Invoices tab. You can only delete billable expenses. To delete sales invoices in bulk, you must be in the Sales Invoices tab.

The transaction you have circled was not entered via an expense claim. So it never did appear in the Expense Claims tab and you should not expect it too. Somehow, it was entered via sales invoice #1003. To know how, you will have to post a screen shot of the Edit screen for that sales invoice.

That depends on how it was entered in the first place. You need to provide a narrative of the sequence of events, not just “…entered/deleted things several times in various combinations.”

Almost certainly not. But more information is needed. Nevertheless, thanks for searching the forum first.

Incidentally, you should update your software. There have been some significant changes since your version and over 100 updates. One specifically was targeted and Windows 7 users.

Thanks for the in-depth reply, sorry if my original one showed my ignorance! Yes, I had clicked the “batch delete” button, just didn’t explicitly mention as it was shown in batch delete mode. The problem here is that there is no corresponding entry in the invoices/expense claims screens where they should be, so there’s nowhere else to even try and delete it. Hence I was using this screen, which is the only one I’ve found which shows the offending entry.

Given it is a debit, not a credit, I thought it must be from an expense claim, not an invoice? I guess I could have entered a negative amount in invoice 1003 but I don’t think I did that! The other fields which are actually type-specified are blank, which makes me think it’s a bit of a buggy entry.

Invoice 1003 only has expense two entries in the edit screen, which are the ones which correctly appear, but there isn’t a third entry to correspond to this rogue item.

To test, I edited the entries of Invoice 1003 to see what happened in the summary - I changed from £15.30 to £15.75 in the invoice, and then the rogue transaction automatically changed from £15.30 to £16.20 to compensate!

Sorry - I would have if I could have! I can’t remember the myriad sequence of dozens of changes during testing over a 15min period. Not a simple “I clicked this one button”, hence my vague summary.

I do try! Yes, I was surprised to see all the updates, I’m used to software where it may take months and I’ve only just started using it but a matter of weeks ago!

What I notice immediately is that, on invoice #1003, you have quantities entered in the Qty field. This suggests that after you created the sales invoice from the Customers tab, you edited it. When you create a sales invoice, the total of the billable expense is populated into the Unit price field, not the quantity and unit price for an individual unit of measure. So, rather than 34 miles at 0.45 GBP each, both of those entries would have just shown no quantity and 15.30 GBP. You, in effect, overrode the automatic invoicing.

Unfortunately, tinkering with invoices created from Customers is a little difficult. You really have to get all the billable items sorted first, then create the invoice. To fix this, you can try reverting to the default entries, as I described above. But that might not address the rogue entry. If not, the easiest thing to do might be to delete the invoice and redo it. That should resolve things. I’m curious to learn the result, because I have not had time to model this in any of my test companies.

As a side question, did you by chance end up with a balance showing in Billable expenses - markup?

Yes I did override it, I wasn’t sure why manager deleted the quantity info. I want the mileage and rate to be clear for mileage expenses.

Yes, the same rogue amount shows up there. I guess as a profit from this mysterious charge. I’m making money out of thin air! Maybe I should just leave it :smile:

I will try just deleting the invoice and re-creating as you suggested.

Thanks for all your help.

Put this information in the line item description. You can edit that without difficulty. The easiest thing is to put that into the description field when you originally make the expense claim entry.

That is what happens when you invoice for more than the billable amount. What puzzles me is that you overrode both billable expenses, but only one showed up as a rogue expense. Well, I’m not going to lose sleep over why the program didn’t behave even worse than you thought it did. Probably something to do with your unremembered “various combinations.”

Be sure and let me know if deleting and properly recreating the invoice fixes things.

Well, I’ve had a chance to model this situation now. In my tests, editing the sales invoice by substituting quantities and unit prices had no effect. Overriding the automatic amounts produced no problem. Amounts showed up in Billable expenses - markup only if I truly marked up the unit price (either individually or for the composite). Nothing I did could generate anything like the rogue entry you are experiencing.

If deleting the sales invoice and recreating it from the Customers tab doesn’t fix your problem, @lubos is going to have to look at this.

I’m pretty sure this is a bug now after testing. I’ve upgraded to the latest 19.9.35 and created a new business to try the same scenario. I am able to repeat it with the following steps (not necessarily the steps that determine it happens, but the steps I used);

  1. Create a new business “test”
  2. Enable customers, billable time, billable expenses, sales invoices, and expense claim tabs
  3. Enter a new expense claim payer “test person”
  4. Enter a new customer “test customer”
  5. File a new billable time entry to “test customer”
  6. Clone first billable time entry and change the date for a second entry the day after, then click create.
  7. Create an expense claim for the same day as the first billable time - assign to billable expenses account for ‘test customer’. Appears to happen with any combination of text / amount.
  8. Clone expense claim and change the date for a second entry the day after
  9. Go to the customers tab and click on the blue text under ‘uninvoiced’, this shows the two billable time entries, and two billable expense entries as expected.
  10. Select all items, then click “new sales invoice”
  11. Click to go to the summary tab - the full amount for the sales invoice shows up in “accounts receivable”, but there is a duplicate of the second billable expense entry, whose amount shows up in both “billable expenses” and “billable expenses - markup”.

Attached is the uploaded test business manager file showing it.

3f590b6fc15c4a008f998e22debdeb61.manager (28 KB)

EDIT: I did as you suggested and didn’t override the expense mileage info, I just let it lump it all together.

Thanks, good suggestion, I’ll do that from now on anyway, even if it doesn’t seem to help this particular issue you’re probably right this is better as it fits in with the flow of how manager does things.

@tut or @lubos are you able to confirm this is a bug? It still does it if its just two billable expense entries, without the billable time.

There are already three bug reports concerning billable expenses that are probably related to this. Every complaint involves slightly different reported behavior, because everyone’s circumstances were a little different. But they all involve errors from conversion of uninvoiced billable expenses to invoiced. Let’s see if the fix for those fixes this problem, too.

Yes you’re right, looks like it is after reading Billable expenses bug.

On my test business if I re-create the same steps, but create the billable expense new (instead of cloning) then it works correctly.