Batch create Billable time coming as Uninvoiced

Hi Experts,

I recently upgraded my Manager desktop version, and noticed that when I now create billable time entries in batch, all the entries are created with status as Uninvoiced, even though I pass the status as WrittenOff during the batch creation.

Please could you help let me know in case there’s anything I need to fix on my side after upgrade. All other details are recorded correctly except for the status.

Thank you.

Can you explain more about your workflow? Why do you Batch Create billable time entries only to simultaneously write them off? That does not seem to make sense.

1 Like

Can’t replicate it on Cloud Edition version 21.11.14.

You can do provide the following:

  • Edition and Version of Manager
  • Edit screen of one of the affected records with the status dropdown menu active.


I am using desktop version 21.10.35

We record billable time just as a timesheet option, but do not actually use it for invoicing. The billable time is used internally for reporting purpose, that is why we need the record writtenoff immediately so that it does not appear on the summary tab (billable time-movement).

We were previously on desktop version 20.10.58 , wherein the immediate write-off worked during batch creation.

Thank you.

Hi, I tried creating an entry through Batch create option with “Invoiced” status, and still the record shows it as Uninvoiced. So it seems irrespective of what I pass under the Status, it is always considering the records as uninvoiced.

Thank you.

Hi Team,

I found the issue; not sure if this is something which can be fixed in the next version, since it seems to be an inconsistency issue between the date format of Batch update v/s Batch Create.

Below are the details, sorry for it being so lengthy :slight_smile:

Since I upgraded recently, and there are now new fields like Division which come up as well, my excel sheet template had to be updated. To do this, I used the Batch update option to get the new file format. When I copied the data (through Batch Update clipboard) to excel, the data was automatically populated. As per the screenshot below, the date format of column A is different from that of Column J (Written-off date). I used the same date formats to create my new records, and that was the issue. It seems for Batch create option, the date format of column J should be the same as that of Column A. When I updated the date format of column J (Written-off date), the records were updated correctly.

Thank you.

Then this :point_down: might be good news

New fields shouldn’t be a problem, it’s renamed fields that you should worry about.

Manager accepts date formats set by the user in the Settings. However, once you paste the data into your spreadsheets, the spreadsheet formating is the one that gets displayed instead.

To avoid these problems, you should align your date formats between your computer and Manager.

But you didn’t tell us whether your problem got solved?

Yes, the problem was resolved after I changed the date format in the written-off date column. :+1:

Thank you, for the quick responses. Manager rocks !!!

1 Like