AppImage does not work

I downloaded Manager.AppImage and made it executable. When I try to pen it I get the folowing message:

19.10.36:SQLite.SQLiteException: ReadOnly at SQLite.PreparedSQLiteinserCommand etc.

What is goiing wrong?

Can I send a screenshot of the whole message?

If you’re using linux you need to open a terminal in the folder where is the AppImage and do:

chmod +x Manager.AppImage

After that it should open. You need to do this every time you update the AppImage too.

I allready made the AppImage excutable, but I dit it again.

I still get the faillures, see the screenshot I send to you.

I hope it can be solved.


I suppose a program on my machine is conflicting with SQLite. I don’t know which program, but i tried Ubuntu 18.04 from usb on this machine and then AppImage worked.
Does anybody know how I can determine which program also use SQLite, so I can turn it off to try again.

A lot of programs use SQLite for various items, but I do not think that’s the issue at hand.

The error is a read-only, so the program has issues accessing the files in
either the default location ~/.local/share/Manager, or wherever you set it to perhaps?

I also tried the AppImage on an other machine with Ubuntu 19.10 and then it works perfect. I can’t believe it will not work with Ubuntu 18.04 on my main machine.
Maybe anyone can help me to find out where the SQLite faillures are from.

I have today run into a similar problem with Ubuntu 18.04.03. This was earlier today on a fresh new build of 18.04 (was freshening-up my PC with an new up to date build).
Oddly enough, on running into this problem, I tried it on a laptop which is already running 18.04 and it worked just fine… Colour me confused…
So, I was wondering if any progress or resolution was made on this question. (screenshot)

Can’t reproduce. I just downloaded 18.04.03 and launched as live CD via VirtualBox and AppImage works out of the box.

I think yours something to do dependency libwebgtk, not the same issue as the op. which is file permission.

1 Like

Many thanks for the (now obvious) pointer…
Indeed, libwebkit2gtk was not installed, and furthermore was not available until the Universe repo’ was enabled.

1 Like

I can’t figure it out the solution. The error seems point to library or data corruption. for op.

Odd enough the app image should not have issue with sqlite,. Libwebgtk is known not packed with the appimage since it already pre-installed in most ubuntu distros.

Just for the safe side restart computer. try redownload the app image. and make it executeable again. and execute it.

Oh interesting keyword there. “manager.upgrade.process”

Question. do you download latest appimage? when the last time you upgrade from the old version which is not the appimage?

1 Like

Here’s an idea. It’s a bit scruffy but might at least prove or disprove your point.

Download the latest appimage to somewhere convenient (and remember where you put it).
Navigate to your .manager data file wherever that may be (say for example ~.local/share/manager or wherever it happens to be).
Make the permissions on the .manager file 666 (rw-rw-rw-).
Using your graphical file manager, right click on the .manager file, and then Open With, then choose to open it with the appimage, and see what happens.

At least, now it works. The problem were the rights of the .manager file.
Thanks for the help.

1 Like