DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

About update new version 13.12.0


#1

How can I update new version of Manager 13.12.0?
Thanks for a great product


#2

Usually you can click on “Check for Updates”, but on mine it’s been saying I have the latest version for ages! I didn’t know there was a new version.


#3

I’ve just downloaded the latest from the web site and there isn’t a “Check for Updates” button any more. Also where are the release notes for the new version so’s we know what has changed?


#4

Right, I’m currently in the process of “fixing” update process. What was wrong with it?

  • **Windows: ** It worked OK but there is an easier way, rather than going to website, making download etc. Manager will be bundled with specialized updater app which will do the update process with fewer clicks. Don’t worry, it will not run in the background and bug you when it’s least convenient. You will be still in control.
  • Mac OS X: I’m in the process of submitting Manager to AppStore. Apple rejects all programs with its own update mechanism because AppStore comes with its own auto-update model. I’m forced to use it if I want Manager to be in AppStore but that might be a good thing.
  • Ubuntu: Similar to Mac OS X situation, Ubuntu Software Center has its own update mechanism. Right now, what is happening is that you install the latest Manager from the website, then Ubuntu Software Center will replace it with its own outdated version.

So basically I’m trying to implement upgrade mechanism which is native to given operating system. A lot of support enquiries are related to installation and upgrading Manager. I’m trying to fix this to offload myself so I can move on and work on features.


#5

I had also noticed that no new updates had appeared in a while, but didn’t think much about it.

Now I’ve just downloaded the new version from the website, and your right the ‘Check for updates’ is missing. Also, it now doesn’t ask me to login, it logins in automatically. Also, no longer got the choice to choose between Online/Offline accounts.

Hopefully all will be fixed soon!

UPDATE Now I’ve just gone into one of my accounts, and data is missing. Invoices/Transactions etc from the date 21/11/2013 onwards.


#6

I don’t think that would be caused by the upgrade since new version didn’t have any changes other than removal of “Check for Updates” and “Cloud Storage” buttons.

Here are the links to previous version

Windows
http://cdn.manager.io/downloads/v13.11.5073.14603/Manager.msi

Mac
http://cdn.manager.io/downloads/v13.11.5073.14603/Manager.dmg

Ubuntu
http://cdn.manager.io/downloads/v13.11.5073.14603/Manager.deb


#7

Hmm strange then!

I downloaded an older version (Mac) logged in downloaded a backup and then imported it into the new version. Although, sometime this week I’ll be updating to the Server edition :slight_smile:


#8

What is really strange is that I downloaded the latest, installed it, ran it and then exited. All OK so far. Then when I tried to go back in, the shortcut couldn’t find the Manager.exe file. I noticed that the whole install folder has been emptied and I had no privilege to be able to reinstall back into that folder. I then tried again into a folder under MyDocuments and the same thing happened. I then reinstalled the previous version which is now operating fine.

I liked the Check for updates button. It was easy, and also presented you with a change log, which we don’t get now.


#9

where are we now?
are the 13.12.0 bugs fixed? Can we move to that Version?


#10

I’m still on 13.11.5073 14602. I keep clicking the “Check for updates” but it tells me I’m on the latest. Still too scared to do an upgrade from the web because of me previous problems.


#11

13.11.5073.14602 is the last version which contains Cloud Storage. So if you had your data in cloud storage, 13.12 version won’t see this data and you will need to follow tutorial at http://www.manager.io/cloud-storage which explains how to move your data from cloud storage (v13.11) to local storage (v13.12).


#12

Confused still - how do we get updates now?

-Jerry