Upgrading Server Edition from Old Mono version

Thank you @PFIVE I got SSL working but it just shows the Apache page. I thus fail to implement:

When typing list 8080 or list IP:8080 it does not show manager but Apache homepage at best. Any further guidance appreciated s t the moment can only use on insecure http://ipaddress:8080 while in the past before updates when caddy worked I actually could use it in https://domain/subdomain (I do not even manage anymore to install it and get it to work in a subdomain such as https://domain/manager Wished I never upgraded, but at the same time also know that upgrading is important to keep going along with approaches and updates. However, this change away from Nano seems to cause quite some suffering without warning or resolution. An install should not be some cumbersome, it was working for a good time following Ubuntu instructions, including upgrade on the Manager.io site but somehow this discipline to present instructions that work now makes us depend on forum discussions and goodwill of people like @Tut or @PFIVE in this instance. I would advise to either remove the server instructions or update them so they work on a plain vanilla Ubuntu webserver. Thanks

Please note that it my view it has become a Manager issue as previous installs following https://www.manager.io/server/installation/ubuntu/ including caddy did work effortlessly and was easy to updateā€¦ until Manager changed, no longer is using mono and caddy install as prescribed disfunctional. I should have realized when following the ā€œUpgrading Manager Serverā€ instructions when the site failed to show again that there was a serious issue that does relate to Manager and the installation instructions that now fail to complete working with SSL on the internet.

@eko - totally agree with you there that the tutorial should be updated to reflect changes to caddy or the apache optionā€¦that is something for the developer to consider.

back to your issue, can you let me know what have you done when you say ā€™ I got SSL working but it just shows the Apache pageā€™ - if you got apache running great youā€™re one step closer. Could you respond to the below listā€¦The approach we will take first, get manager to run with apache without certificate, second, we apply the certificate from letsencrypt.

First checklist, note that when one answer is no, you need to fix before moving on;

  1. Is Manager running?
    systemctl status manager-server
  2. Can you access Manager direct from http:yourinternalip:8080?
  3. Apache - can you confirm that apache installed and confirm apache default page opening? just IP address without the 8080 port
  4. Setup apache redirection to internal port 8080;
    sudo a2enmod proxy
    sudo a2enmod proxy_http
    nano /etc/apache2/sites-available/000-default.conf

Replace the text with below - note to customise to your details where it says yourdomain.com

<VirtualHost *:80>
ServerName yourdomain.com
ServerAlias www.yourdomain.com
ErrorLog {APACHE_LOG_DIR}/error.log CustomLog {APACHE_LOG_DIR}/access.log combined
ProxyRequests Off
<Proxy *>
Order deny,allow
Allow from all
</Proxy>
ProxyPass / http://localhost:8080/
ProxyPassReverse / http://localhost:8080/
<Location />
Order allow,deny
Allow from all
</Location>
</VirtualHost>

Save and restart apache;

sudo systemctl restart apache2.service

  1. Now try accessing http://managerinternalip (without the 8080 as in step #3 above) - if this was done correctly, apache will open manager instead of the default page.

End of part oneā€¦see how you goā€¦and all the best.

1 Like

@PFIVE Thank you! Part 1 success, ie Manager opens when accessing http://ipaddress and also with http://domainname (unfortunately no subdomainā€¦). So the non SSL installation works. Looking forward to step 2 to secure with SSL and maybe even have it in a subdomain such as https://domainname/manager as I had before.

I managed to get SSL working following your earlier instructions

  • Install apache and then enable SSL module:
    sudo a2enmod ssl
  • Use lets encrypt to issue a certificate
    sudo apt install python3-certbot-apache

and finished with:
sudo certbot --apache

As mentioned pity do no longer know how to put it in https://domain/manager

But very happy thank to you that I got this far. Hope @Lubos updates the instructions on server install by replacing the Caddy info with the info you provided + the sudo certbot --apache

To be sure everything would work well, I also followed up with the instructions on Upgrading Manager Server. This resulted in a disappointment, ie error. However, just repeating the complete install instructions ā€œinstalling Manager Serverā€ AND ā€œInstall Manager Server as a serviceā€ worked. So basically any ā€œUPGRADEā€ just needs to follow this.

Great job so far and good to know its workingā€¦the domain part should be the easier setup compared to what you have accomplished.

Just point your subdomain to the ip address of the server by using your DNS managerā€¦

Create an ā€˜Aā€™ record;

sub.mydomain.com --> your IP address

then you try again accessing using your customised nameā€¦

Thank you that works in that i can now use manager.mydomain.com and mydomain.com/manager. However, it then just shows for example https://mydomain/businesses thus kind of redirect rather than serving all from e.g. https://mydomain/manager and not showing anything or a holding page when using https://mydomain. So what to do?

i just installed Manager on Centos ontop of Nethserver. to handle the SSL renewal and validation. saves me the trouble i have had the whole week.

maybe this link helps; new Caddy v2 and new install guide for server ed

@eko et al, @lubos has posted an update to his guide, check out: