Error when trying to install in Ubuntu

Have tried to download the latest version from the website and when I try to open the application to install in Ubuntu I get:

File type Debian package (application/x-deb) is not supported

How do I get around this?

Try to install Dropbox from Install - Dropbox and let me know if it works.

Gives the same response File type Debian package (application/x-deb) is not supported

That means you have some deeper issue in your Ubuntu. You basically can’t install any DEB package from any software vendor so this is not really a Manager issue.

Try to use gdebi to install your .deb files.

sudo apt-get install gdebi

and then right click on your downloaded Manager.deb file and open with gdebi

In my Ubuntu, the file association got trashed and the system opens .deb files with the wrong application. As a work-around I do the following:

  1. Close Manager if it is currently open
  2. Open FireFox
  3. Type Download | Manager in the address bar, then press ENTER
  4. Click download button, click Save file, click OK
  5. When the download completes, click the green arrow in the FireFox toolbar
  6. Right-Click the most recent Manager.deb file (it should be the first item in the list) If you downloaded more than copy of Manager the most recent file shows as Manager(?).deb where the ? is replaced with a number. The most recent download will have the largest number.
  7. Select Open containing folder from the context menu.
    The file you selected will be highlighted in the window that opens. (You may need to close or minimize FireFox to see the file window.)
  8. Right-click the highlighted Manager file and select Open with Ubuntu Software Center on the context menu.
  9. Wait for Manager to apper in the Software Center menu. Click on the Update button at the far right side of the Software Center window.
  10. If a window opens asking for a password to install files, type your password then press Enter
  11. When a green check mark appears under the Manager icon in the Software Center window you may close the Software Center and start Manager as you normally do.
  12. Click on About Manager to verify the version of Manager that opens. The version number should match the number you see below Ubuntu in FireFox.

This is the full error I’m getting trying to install from repository and download…

The following packages have unmet dependencies:
libmono-wcf3.0a-cil : Depends: libmono-system-web2.0-cil (>= 2.10.3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

What Ubuntu version are you using? I will try to reproduce.

Ubuntu 14.04 LTS
Memory: 15.7 GiB
Processor: Intel® Core™ i7-2600K CPU @ 3.40GHz × 8
Graphics: GeForce GTX 550 Ti/PCIe/SSE2
OS Type: 64-bit

Could you run these two commands before installing Manager? See if it resolves the issue:

sudo apt-get update
sudo apt-get install libmono-system-web2.0-cil

Get the same error, here is the full explanation returned:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libmono-system-web2.0-cil : Depends: mono-runtime (< 3.12.2) but is to be installed


sudo apt-get install mono-runtime

then try to install Manager again.

For the record, I’m unable to reproduce this issue on Ubuntu 14.04 LTS so far.

I already have the latest runtime, probably there’s a conflict because I use to program with Visual Studio Code for Linux and during installation installed some libraries and remove others from the mono dependencies which conflicts with them.

It keeps asking to install dependencies and to downgrade mono-runtime, I will test this in the other Linux box I have.