DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

Supplier Custom Field Showing on Statement...TWICE?


#1

Not sure if it’s a problem or I’ve done something wrong.
I do use custom themes but my understanding is that Statements don’t have themes available.
I only have the Customer Acc No available as notes with suppliers (as pictured) and for some reason the only field in the Supplier notes that shows on the Statements is that one, even though there is information in all the other Custom Fields for the Supplier. And it appears twice. It is also the only one that has Show custom field on printed documents ticked, but if I tick the others they also appear twice?.
CUSTFLD


Should customer/supplier custom fields show on transaction forms?
#2

Refresh? Try change telephne position to 2 and the rest to increment number respectively


#3

This is not true. Read the Guide: https://guides.manager.io/7022.

Are you asking if this will happen or telling us it does happen? Regardless, I think @acecombat2 is probably correct in thinking your problem comes from having two custom fields fighting for the number one position.


#4

my understanding is that Statements don’t have themes available.

Maybe I should have said fields, not themes.

Changing the positions to all different ones made no difference.

What I am saying is that if you tick Show custom field on printed documents in the Supplier custom fields they appears on the Statements…Twice (All of the ticked ones). There is no option anywhere for custom fields on Supplier Statements. (Which would be handy but is a different topic).


#5

what version are you using?

also, is this happening on the plain default theme? or have you selected any custom theme for your statement?


#6

@lubos this looks like a bug. 18.1.84

the custom fields for Suppliers are appearing twice on the statements with default plain theme.

i only have the default Telephone custom field for Suppliers and when this is set to show on printed documents, it appears twice on the statement.

i have checked the custom fields for Customers, but this does not seem to happen on the customer statements.


#7

Version 18.1.88.

Thanks @sharpdrivetek. It’s actually been doing it for a while,


#8

I have confirmed this is a bug. It applies only to Supplier Statements. But it applies to both types, Unpaid invoices and Transactions, whenever the custom field defined for suppliers is checked to show on printed documents.

I will open a separate topic on whether custom fields defined for customers and suppliers should show on transaction forms in the first place.


#9

Fixed in the latest version (18.1.94)