Printing Issue

I am getting the same issue here, i am trying to send the invoice via email, but i get the same error

DocumentSaveException: Exception of type 'Apitron.PDF.Kit.ErrorHandling.DocumentSaveException' was thrown.

When trying to generate a PDF i get the following error

DocumentSaveException: Apitron.PDF.Kit.ErrorHandling.DocumentSaveException: Exception of type 'Apitron.PDF.Kit.ErrorHandling.DocumentSaveException' was thrown.
  at Apitron.PDF.Kit.FlowDocument.Write (System.IO.Stream outputStream, Apitron.PDF.Kit.FixedLayout.Resources.ResourceManager resourceManager, Apitron.PDF.Kit.FixedLayout.PageProperties.PageBoundary boundary, Apitron.PDF.Kit.PdfStandard pdfStandard) [0x0009e] in <15ac2733cdf44d7791f26e66c97e5318>:0 
  at ManagerServer.PdfConverter.ConvertHtmlToPdf (System.String input, System.IO.Stream output, Apitron.PDF.Kit.FixedLayout.PageProperties.PageBoundary pageBoundary) [0x0047e] in <d9f6cffb72c64a8793ae14ec7b0640cd>:0 
  at ManagerServer.HttpHandlers.Pdf.Post () [0x0015b] in <d9f6cffb72c64a8793ae14ec7b0640cd>:0 

I am working with the latest version at the moment

@justie75, I assume you are also using Mac, correct?

Hello lubos, yes i am using manager on my MacBook Pro

Hi Lubos

Is there anything that can be done for us on this issue? Grateful for any reply…Cheers David

This is a bug specific to Mac OS X on some businesses. I hope to have it fixed by end of this weekend.

2 Likes

I run Manager 15.7.3 on my old 2009 Imac on 10.9.5 with no problems but when I tried on the new machine I struck problems. Still cannot email any quotes out on it.

good evening.

Have you solved the problem of printing?
And the PDF creator?

Greeting from the Netherlands

There have been many problems and rapid updates. To see if the one you are asking about is fixed, update your software and try it out.

@Tut I have been having problems with the PDF button on all my mac computers, it kept giving an error to say could not open, file damaged.
I realised that I could open invoices I had copied to myself on my iPad and my HTC phone.
This made me think it must be a problem with my Adobe Acrobat Professional ver 8.0., and not a Manager problem

I downloaded PDF Reader X to my MacBook Pro, selected this as the programme to open PDF files, and now I can use the PDF Button

@Tut Just a follow up, I went to my iMac, deleted the Adobe Acrobat Professional 8.0, select the PDF button and it opens in Preview, so again Adobe Acrobat was the cause, but how to fix it, I do not know.

I have encountered many situations where a PDF file behaves one way with Adobe Acrobat or Reader and another with Preview. Some files open and/or display correctly with one but not the other. And it isn’t always one program that causes difficulty. So I have set Preview as my preferred app for PDF files, but sometimes need the others. You don’t have to get rid of it, you can just make Preview the preferred one.

i followed your steps and the same error happened again ??

@Adel_Elkady, did you got to a known PDF file on your computer, and select open with, tick the box which says always open with this programme, then select preview, or PDF reader X if you have downloaded it. Try that hope it helps

Lobos than you so much for your support the Manager new version fixed all the error thanks

@Adel_Elkady, @norfolkislandam, @Frans, @David_Hancock, @justie75, @AAmey, I am trying to clean up this forum topic. Many updates have occurred since some of you posted, and it looks like your problems should have been cleared up, but it is impossible to tell for sure. Would you please let me know if you are still having a printing problem? If I don’t hear from you within a couple days, I will clear this bug report.

If you do have a problem, please open a new topic and describe it so it can receive proper visibility and attention. Thanks.

The last version is a very stable one and it has no problems thanks for your support

Thank you Tut…I downloaded again and my problem with email is resolved. Cheers David

The latest version has fixed my problem :wink: Thank you alot!

Nearly everyone who replied at any time on this subject has indicated their problem was solved. I am removing this topic from the Bugs category and closing it to further postings. If you have a problem, please start a new topic.