Presentation of Balancesheet Report - Copy to clipboard extraction

Report Displayed Correctly in Manager.
But Equity and retained Earning value are extracted in inversely.

Above … Photo 1 - Report display in manager. (Absolutely Correct)


Above… Photo 2 - After Copy to clip board function use…(Value Changed) Equity + Retained earning value are multiply with (-1) so Our basic equation (Assets = Equity + Liability) proves wrong in that condition.
Please correct this ASAP.

This is actually expected behavior; Manager stores debit balance amounts as positive numbers, and credit balance amounts as negative numbers “behind the scenes” and only changes the presentation for the report while in the program.

When you copy into a spreadsheet, you are copying the actual numbers from behind the scenes. You may want to give the suggestion from this topic a try;

You could also change the signs for Liabilities and Equity by using a formula in your spreadsheet — e.g., =cell * -1 — and then simply carrying it down the rest of the column.

For what it’s worth, I am a practicing professional accountant and would not consider anything wrong with your balance sheet as it appears in Photo 2; in fact, that is how the professional software I use would display it.

Understand. But As per my view… Manager team need to correct this. Because at the time of Copy to clipboard function… we need to extract data which is display on screen. We do not need the data behind the Scenes.

it’s not practical during Each time…

I cannot imagine why you would not want the actual numbers. Nevertheless, you can accomplish what you want by dragging over the screen display, copying, and pasting into a spreadsheet.

Yes that works correctly… By that method we get correct numbers but with the hyperlink… and after that we need to remove hyperlink manually(By selecting whole data and then remove hyperlink function we can done this by 2-3 click only). But then also I feels that, Team manager needs to correct the copy to function… because for the accounting software there are much more importance of + and -.

For prevention for the user, Manager team needs to extract the displayed data with copy to clipboard function otherwise user get wrong numbers of Equity and liabilities. and our basic equation (Assets = Equity + Liability) proves wrong with Copy to clipboard function. So please look into this. :face_with_monocle:

@AaiRiz the data as per photo 2 in post 1 in the spreadsheet is not wrong! It is just another presentation that is legal to use as well. Let me explain with your example: You show Assets is +1,65,663,91 this is what you own and you show Liabilities is -22,966.96 and Equity is -1,42,696.95. The sum of Liabilities and Equite is -1,65,663,91 and depicts what you owe but already as subtractables from what you own (Assets)

The assumption is that If you would sell what you own you should get +1,65,663,91 from which you can clear what you owe -1,65,663,91 giving a balance of 0. It is a matter of presentation, do not forget that in the basic equation (Assets = Equity + Liability) you refer to you need to realize that they imply standard Credit and Debit notations, i.e. Debit (D) (Assets) on the left side and Credits (C) (Equity and Liabilities) on the right side. The basic equation is thus (D) Assets = (C) Equity + (C) Liabilities or where D = (+) and C = (-). In simple terms when the value of an Asset Increases (D) then the value of (Liabilities and Equity) decreases (C).

1 Like

I agree. I would also offer what may be a simplification; the accounting equation is basic algebra, meaning (Assets = Liabilities + Equity) is the same as (Assets – Liabilities – Equity = 0).

However, I think @AaiRIz brings up a fair point in post 4 they did not previously touch on; not every user of accounting software is knowledgeable about accounting. If the alternative presentation is confusing for the other users or staff, @Tut’s solution seems the best.

1 Like

Not when in Excel you either right-click and select the second option Match destination formatting (M) or right-click > Paste Special > Unicode Unitext

1 Like