OS-X Server Issue


I have just upgraded to latest version of Manager Server.

I downloaded it from the most recent link: ManagerServer-Mac-x64.zip

I have installed file as usual and followed the new launch instruction “./ManagerServer”

But I get -bash: ./ManagerServer: Permission denied

Any help would be appreciated, I am running OS-x 10.15.6

I have never tried the OSX version of server, but if you’re getting a permission error, look at where manager is installed, who has access to run it and make sure you’re that user. You should be, but it’s weird.

  1. Where is it installed?
  2. Navigate to that folder in terminal and type: ls -al and check the user and group assigned to the manager folder and then the files within it.
  3. Is that the same user you are logged in with? (it should be). I only run Mojave and so I have no idea about security issues and permissions for anything higher, it’s possible there is an issue there.


On a small Mac-Mini we use as the Server in the office.

I’ve checked that and it appears all the files are correctly loaded and User and groups are assigned.

I have downloaded the desktop version and everything is working ok, So it must be a issue with Server Version.

Is there still a need to use Mono?

The latest version doesn’t use Mono anymore.

ManagerServer is native OSX binary now.

Can you run

chmod +x ManagerServer

and then



Thank you that worked perfectly.

You should add that new detail to the server download page, just in case anyone else gets stuck

That is an issue I use to run across often in linux, just because something should be an executable, doesn’t mean it is so when it’s installed (un-archived), although not exactly permissions based, it kinda is. It is a permission to execute a file and although that’s not what I was looking for in my ls -al request, it would have been picked up.

Good to see it fixed and running.