Managerserver show Application_Data_Location

Hi,managerserver show Application_Data_Location when run manually but run with nssm not show Application_Data_Location pls anybody help me

I’ve never heard of non-sucking service manager before, but I suspect you are not fulfilling the requirements for what it may need that’s equivalent to the systemctl default service manager.

I am going to guess your problem is related to the user that runs it. When you run it, it is your user and the application data folder is based off your working directory. The service manager will usually be root and so the directory is going to be off the root folder. Go and have a look in there.

Alternatively, set your service manager to pass in a custom path through passing in an argument, that way you can explicitly set where you want the directory to be. However, do be mindful of user permissions!


 /usr/share/manager-server/ManagerServer -port 8082 -path /root/.local/share/Manager/

(both port and path are optional and you do not need to specify either

  ManagerServer.exe [options]
  -port [number]     Set port on which HTTP server should listen on.
  -path [directory]  Set directory where Manager should look for data.
  ManagerServer.exe -port 80
  ManagerServer.exe -port 80 -path "/root/.local/share/Manager"