Linux Mint (Mate) internal error on load


Every time I open imported business I get the below error

Internal Error
17.12.3 (Desktop)
SQLite.SQLiteException: *** in database main ***
Main freelist: 1 of 3 pages missing from overflow list starting at 154
Page 174 is never used
wrong # of entries in index sqlite_autoindex_Objects_1
at Manager.ApplicationData.Get (Guid entityId) <0x4150da00 + 0x002cb> in :0
at ManagerServer.HttpHandlers.Businesses.Business.Start.Get () <0x415fada0 + 0x0009b> in :0
at HttpFramework.HttpApplication.ProcessRequest (HttpFramework.HttpRequest request, HttpFramework.HttpResponse response) <0x415ac340 + 0x00854> in :0
at ManagerServer.HttpApplication.ProcessRequest (HttpFramework.HttpRequest request, HttpFramework.HttpResponse response) <0x415a9090 + 0x017a3> in :0

Just will not open in Linux 18.2



This issue has now been resolved. THANKS


That’s great.

It may be helpful for others if you post the solution that worked for you.

That way, if anyone else comes across a similar problem in the future, your solution can help them.


ShaneAU, I really not sure how I fixed it but after having the same issue on windows PC I uninstalled all versions and copies of Manager, then reinstalled with latest version on both linux and windows. Used a back up file (I back up everyday) for the business and imported that. and no error.