AppImage fails to load "stack smashing detected"

Version 21.10.5 and the previous version I had both did it. I’m on Fedora 35 (Linux).

Gtk-Message: 18:54:51.463: Failed to load module "colorreload-gtk-module"
Gtk-Message: 18:54:51.463: Failed to load module "window-decorations-gtk-module"
Gtk-Message: 18:54:51.892: Failed to load module "colorreload-gtk-module"
Gtk-Message: 18:54:51.892: Failed to load module "window-decorations-gtk-module"
*** stack smashing detected ***: terminated
/tmp/.mount_ManageUqrXKD/AppRun: line 4: 605540 Aborted                 (core dumped) ${HERE}/opt/manager/ManagerDesktop
1 Like

Not sure if this is the same issue, but the last AppImage I had was 21.8.37 and the app opens OK, but when opening company it crashes and returns,

*** stack smashing detected ***: terminated
/tmp/.mount_ManageEs91By/AppRun: line 4:  3583 Aborted                 (core dumped) ${HERE}/opt/manager/ManagerDesktop

Each time I run the AppImage, the value after "line 4: " is larger than the last. I am unsure if this is a timer value or something else?

Updated to 21.10.3 a few days ago, but still have same errors.

Just updated to 21.10.6 and still same errors.

I have tried importing known working backups and they do the same.

Arch Linux 5.14.9-arch2-1, updated and rebooted today.

Looks like the same issue. Mine just has extra warnings about GTK as I run KDE Plasma.

Today I tried creating a new business. I am able to set a name, but when I click Add Business, it crashes with the same errors posted before.

I can reopen Manager, and the new Business name is listed, but trying to open the business fails with same error.

No problem here with v21.10.6 on Ubuntu Mate 20.04.1 Desktop AMD64.

@Mark, I assume AppImage?

I am going to try to spin up a virtual machine to see if that will work, but haven’t found the time. My invoicing is getting delayed, so I need to make the time though!

I just tried 21.10.7 as well and it’s the same error. I believe the number that increments in the error message is just the PID (Process ID). It’s just the number given to each process when it starts.

1 Like

Indeed, so there’s no problem with the AppImage.

Any news on this topic? I can no longer access my data either and seem to be having the same issue.

Or there is a conflict with another application, and you either don’t have it installed or you just haven’t gotten an update yet for it?

I have the exact same issue on Fedora 35. Has anyone found the fix yet?

I think you have the same bug with gtk3 as manjaro or arch user. Downgrade the Package, is the fix

That was indeed the problem. Thanks!

I fixed it on fedora 35 temporarily with the following command:

sudo dnf downgrade --releasever=34 gtk3

In Archlinux downgrade to the last version of gtk3 that works with this command:

sudo pacman -U

I have been having an issue with manager (new install) on both Fedora 35 and Manjaro KDE and Gnome (ver 21.1) and it starts but crashes when clicking on a business (either imported or new). Followed the above mentioned ‘fixes’ but doesn’t do anything. Any suggestions?

Make sure to lock the version of gtk3, so that it doesn’t get changed again when running an update. With fedora you can use the versionlock command:

sudo dnf versionlock add gtk3-0:3.24.30-1.fc34
sudo dnf versionlock add gtk3-devel-0:3.24.30-1.fc34

Hi friends, did someone know if the bug exist on newer packages of gtk3-0:24.30-90+ and above?

I haven’t tested it so far. If you do test it, let me know if it works for you.

Hello again, i little bit late sorry,
i tested it after the big update from manjaro, and it breaks manager accounting again.
Also downgrade the Version gtk3-0:24.30-60+… without tracker again.

Downgrading gtk worked for me too. Fedora 35