Invalid File Format

I am only running the newer version on the computer but since it would not open the backup I uninstalled and reinstalled an older version to see if it would work with the backup file which it didn’t.

  1. Backup as in clicking the backup button to get the “Business backup”
  2. I had to reformat my SSD because windows 10 creator update decided to peg my C:// at 100% constantly.
  3. Reinstalled being the newest download version

  1. Have tried it on a different computer but it also has the Creators update and brings up the same Invalid File Format.
  2. I have completely uninstalled all traces of Manager and reinstalled the newest version it did not help.
  3. I have re-downloaded the 18.1.8 update and no dice.

I guess I will wait a couple of days. I am also going to try installing it on a friends computer that isn’t windows 10 today to see if that does anything … Don’t know if it will but worth a try.

Also read the reply the user made after this, the problem seemed to be solved.

@Anubidin, for some reason, you are the third person in the past few days with the exact same complaint. Your degree of understanding on how the Manager program works is not clear. So first, are you aware that there is an application (the program itself) in one location and a group of data files containing the actual accounting data and supporting information in a separate application data folder? That data folder is the right side of your screen shot.

When you launch the program, it looks in an index file to see what businesses you have added and where they are. The index file is the first one with all zeros (and no hyphens). The two files with hyphens in their names are obsolete relic files. Move them to a safe place outside the application data folder. You should not need them, but do not delete them yet, until we make sure.

Your data should be in the file beginning with 71… that @sharpdrivetek mentioned (the one without the hyphens). But you may not be able to open it directly, depending on what version of the program it was created with. You need to launch the program and open it from the Businesses page.

Since you have now played around quite a bit trying to recover your data, it is possible the index file got corrupted. So if you do not see your business listed on the Businesses page, click the Add Business button and follow through with importing that file with the name 71… You will need to be sure your file search is set up to show hidden files, or navigate to the application data folder by pasting the folder location into the search function. When the file opens, it may have the long, hexadecimal name instead of your actual business name. If so, you can click the Rename button next to the name in the open Manager window to change that.

If the business you open contains your latest data, you can delete those files I asked you to move to a safe location. If it does not contain your latest data, go back to the Add Business button and import the business that has the hyphens in its name. See if that is the correct one. You can read all about this process in this Guide: Manager Cloud.

Once you have found the proper data file using the latest version of the program, it can no longer be opened by an older version of the program, so do not try. When you have found your latest data, make a backup, using the Backup button in the program. Be sure the backup is not on the same drive as the program, or you are wasting your time. When (not if) your drive eventually fails, your backup will be lost along with your main data file. Put the backup on another accessible drive or in cloud storage. Read about that here: Manager Cloud.

One thing that is puzzling is that all your files in the application data folder have the same modification date. This should not be the case unless you did things you have not yet told us about.

The data file starting with 71 as I have previously mentioned is a 2 year old version I tried opening with an older program because I could not get the newer ones to work…

As for the two guide posts none of these work as the fact is the Hard-drive was reformatted so the application data in the Appdata is not related to the latest business backup ( It is the 2 year old version backup as mentioned above) I created before reformatting. I still get the invalid file format.

Also the reason it has the same modification date would because I REFORMATTED the harddrive so it had to create new application data files…

Your replies have been a little confusing. Apparently, if I now understand correctly, you’ve been trying to import and open the same file with two different versions of the program. This is a bad idea, because both versions of the program will be trying to create their own data files and independently update the index file, all in the same application data folder. But at least I understand why everything has the same modification date.

To recover, you are going to have to move all those files out of the application data folder and begin again. But you do not need to reinstall the program. You just need to add your business, something I now know you were trying to do.

The problem is that you have not shown us a real backup file of your actual business. Your very first screen shot shows two files with the backup file-naming format, but both are extremely tiny. These are the size of businesses when first added, before they contain any real content. Even a very few transactions or setup of a chart of accounts would increase their size by a few tens of KB. Using them for a couple years would most likely put you in the multi-MB size range, or at least a few hundred KB.

So your next challenge is to find your real backup, if one exists. Once you do, you can add that business. Hopefully, it wasn’t on the drive you reformatted.

Looking back at that first post, I also notice that you referred to date preferences. The date preference has nothing to do with importing a backup of your business. Your screen shot also shows no file selected for the import. Did you actually browse to a file? And, if so, was it something besides those two tiny ones shown in the next image from your E drive?

@Anubidin - I am also running Windows 10 and recently received a major automatic operating system update and are having no issues with running Manager, but I only have a HHD and not a SSD in the laptop. So Manager will work with Windows 10 after the update.

My application data file just a single file starting with 0000000, but I note from your screenshot that you have two, one with hyphens, I would delete the one with hyphens as its not required, besides it has the wrong file size value. By delete you could just drag and drop into another folder. Not saying this will resolve the issue but could remove a potential conflict.

@tut It is a very casual based business that has been going for a couple years I don’t know if this would impact the file size, but if that isn’t the case then yes I have lost everything because it was on the reformatted drive apart from the two backups I made on different days just before reformatting.

I have also completely wiped the application data and tried importing the business to no avail.

I have one other copy that isn’t on the E drive but it is the same size.

@Brucanna I have had a couple of computers update with the creators update on windows 10 that had no issues (but they didn’t have manager on it) Windows 10 on my computer however had many a issues so it may of corrupted the file I was trying to back up (possibly).

Have tried your suggestion to no avail.

I think I might just be in for a week (hopefully no more :smiley: ) of re-inputting info by the look of it

I don’t think so. One of my test businesses literally has no financial transactions. I keep it for modeling forum questioners’ problems. It has 1 customer, 1 supplier, 1 fixed asset, 1 bank account, and 1 cash account. But there are no invoices, receipts, payments, or anything else. That file is 41 KB.

Conceivably, your 71…. file (without the hyphens) could be large enough at 64 KB. Before giving up, I’m going to invite @lubos to look at that. He may ask you to send it to him. I am fairly sure, based on what you’ve now shared, that the version of that file with the hyphens was from your attempt to open things with the old program. Its 20 KB size is perfect for an empty, default data file.

I’ve got the same error message after reformatting my hard drive. Windows 10 was driving me crazy, so I went back to Windows 7. Now Manager can’t recognise my back up file.

Here is what I suggest:

Try to install version 17.12.61. Here are the download links for each operating system.

Try to import your backup file into version 17.12.61. If it works, then upgrade to the latest version.


That’s awesome @lubos. It worked straight away.
You’re a life saver. Thanks heaps.

Thanks for this! It works. You helped me a great deal.

Right Click on Manager open as administrator and the import the file as the new windows 10 have new security

Thankyou @lubos the older version allowed it to work first time. :smiley: Have now updated to the newest version and is working perfectly fine.

Thanks Lubos.
I uninstalled the current version in the roaming folder and then installed v17 from the link you sent. I have been using the desktop version. Once 17 was installed I received the following error.
Your DB has been upgraded to the latest version while your desktop edition is still an older version. Upgrade desktop edition to the latest version which will resolve this issue. This usually happens when you install server edition of newer version on the same computer .


@techtodd, you misunderstood the instructions. After installing the old version, you were supposed to open the old version of the data base, then make a backup of it. Then import the just-created backup with the new version. If you received the message you described when opening the old version of the database with the old program, that means that at some point you were able to open the data base with the new program. So you have a different problem from the one described in this thread.

You are going to have to provide more details about what you did, in exactly what order, and what happened.

@techtodd yeah, currently once you install newer version of Manager, there is no way back. Try the very latest version (18.1.37) which will launch properly and will allow you to import your business so try that.

Hi Lubos,

If I didn’t make a backup, will I be able to restore anything?
I was thinking if I installed the old version there would be a file I could
point to bringing the data back.
I did uninstall v18 and so I thought I could reinstall the old version then



Your accounting data is not in the application, but in separate data files, one for each business you may create. If you were storing your data in the cloud, that’s where those files are. After installing the latest version of Manager, you will need to add the business(es) by importing those files.

Backup files and regular business files are identical, except the backups are given plain language file names using the business name and a date.

Also, please do not post personal data on the forum. If you respond from email, delete your signature first. I’ve edited you post to remove personal information.