Internal error when creating report


I get this error when I creating report of Sales Invoice Totals by Custom Field.

i am on the same version and i cannot replicate this problem.

have you tried selecting a different custom field in the report? do you still get the same error?

Yes, I get this error when I selecting a different custom field.

i am not sure why you are getting the error.
anyway try updating to the latest version and check if you still get the error.

Ok, thanks.

All errors like this are an application bug, so if you’ve updated and it still happens, lubos should be made aware of the problem. I’ll avoid pinging him until we hear back from you, just in case the update resolves it for you.

I just updated version 18.4.6 but still get this error.

You are going to need to provide more information. For example, can you post screen shots showing your custom field lists from Settings? Also, provide a screen shot or two of sales invoice entry screens with custom fields filled in. Then show a shot of the edit screen for the Sales Invoice Totals by Custom Field you are trying to view.

Okay. The screenshot in the original post might be enough for @lubos to resolve the error message. There is a NullReferenceException when calling GetRows() in SalesInvoiceTotalsByCustomFieldList.

However, it might be a little more difficult to find the reason that the null reference occurred in the first place. If you’re able to provide some of the information @Tut requested, that could help.

Screenshot below:

I don’t have a shot of editing screen because I got the error message when I click Sales Invoice Totals by Custom Field. After I restore my earlier backup, I tested the customer field one by one in the report but it did not happen again. However my last backup still got this message.

Two questions to make sure we understand what is happening, @moem :

  1. You originally said you got the error message when creating the report. Next, you said you got it when selecting a different custom field. Now, you say you get the error when clicking the report name (possibly before any report has been defined). Will you please describe the exact sequence of actions that generates the error?

  2. You say this does not happen with your earlier backup. Please describe any changes made to your Manager setup since the backup that works.


I am sorry to have confused you. Let me explain in detail.

  1. Before I added a Report from Sales Invoice Totals by Custom Field, I added a new custom field “test” in Setting>Custom Field>Sales Invoice — Line. Then I tested it on an Invoice. Then, I created a Sales Invoice Totals by Custom Field Report. I forgot what I selected, it could be Sales Invoice — Line “test”, or Customer “Telephone”. And then I click “View”, I got that error message. After that, I got that error again when I clicking Reports >Sales Invoice Totals by Custom Field. I can’t add, edit, or preview at all. The error message is: object “reference not set to an instance of an object”.

  2. As I mentioned above I added a new custom field “test” in Setting>Custom Field>Sales Invoice — Line. Then I tested it on an Invoice.

I do not know why it didn’t happen again. I have now updated the latest version.

So are you saying the problem has completely gone away? Before, you implied it was only corrected if you used an older backup.

Yes the problem is gone after I restored to my old backup but the file that i did not restore is still got problem.

I want to be certain I correctly understand your situation, @moem. Can you confirm that the “old backup” works with the latest version of Manager? I want to make sure you are not using the old backup with an old version of the program.

If the old backup works with the new version of the program, and allows you to enter new data, edit old transactions, and so forth, then the symptoms indicate some type of corruption of the restored data file. You can verify this by making a new backup from the old backup. Manager will append the current date, so you will be able to tell them apart. If the new backup works correctly, the problem was definitely with the first backup file.

1 Like

Hi @Tut,

I was using my current manager file (2018-04-05) with 18.3.45 version when I got that error message for the first time. Next day I tried to update to the newest version with the current file but the problem still happened. It seems I don’t have any solution so I restore to the old backup (2018-04-02) with the new version. After that, the problem is gone even when I enter some new data and make a new backup from the old backup (2018-04-02). But It never work on the original file (2018-04-05).

OK. It sounds like your 2018-04-05 backup file was corrupted somehow. As long as you can enter and edit transactions and get reports from the 2018-04-02 backup and any later backups made from it, you should be all set. You should Remove the 2018-04-05 business from your list of businesses. See this Guide: Manager Cloud. Since removing a business leaves its data file in your application data folder, you might also want to remove the data file. See this Guide: Manager Cloud.