Impossible to import a bank statement file .Ofx

Since a recent update, i cannot import an .ofx file from my bank as i have a message HTTP 500 internal error…
I have tried with an older file (that have been already imported) but have the same problem…
I have made no change (only updated manager) since last successfull import…

I have tried to come back to an older version (17.11.22) that was working to import .ofx file, but it is not possible to install as the database was already updated with last version…

1 Like

I don’t know if this is related, but another user had an issue with .ofx imports not matching number formats. A recent change to the program (v17.12.12) addressed this. Are the number formats in your export the same as your number format preference in Manager? As I understand things, the program now assumes that they are. If they are not, perhaps that causes problems.

You right , i have change the number format in program preference and could import the .ofx file.
Thank you for your help

I have the same error with the cloud version :
Internal Error

17.12.62 (Cloud)

/import-bank-statement-form?FileID=7ff99795-f127-4254-8ace-1e2048308a54

System.FormatException: Input string was not in a correct format.
at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
at System.Number.ParseDecimal(String value, NumberStyles options, NumberFormatInfo numfmt)
at ManagerServer.HttpHandlers.Businesses.Business.BankTransactions.ImportBankStatementForm.ParseBankStatementLines(String fileName, Byte[] buffer)
at ManagerServer.HttpHandlers.Businesses.Business.BankTransactions.ImportBankStatementForm.Post()
at HttpFramework.HttpApplication.ProcessRequest(HttpRequest request, HttpResponse response)
at ManagerServer.HttpApplication.ProcessRequest(HttpRequest request, HttpResponse response)

Does the number format exported by your bank match your preferences?

The date and amounts look like this:
date: "20171208"
amount : "-2000.00"
My preferences are:
French
123 456 789,00
2017-12-31

I am not sure how Manager interprets different date formats, or whether .ofx format allows different date formats. But as of a recent fix, Manager assumes the .ofx numbers are in the same format as your preference. So you will need to either (a) temporarily choose a matching number format or (b) edit the statement file wit a text editor to substitute a period for the comma as your date separator. I confess I do not know how Manager treats the absence of spaces as thousands separators. Probably it ignores them.

None of the choices we have in preferences matches the one generated by the bank.
the best would be to have an option with comma or dot without any thousands separators.

Did you try importing with the format highlighted in this illustration?

13 PM

Another option is to try importing the .ofx file into a spreadsheet, then define the column with amounts as a number format. You can select a number format available in Manager or define a custom format. Finally, convert back to a text file format and paste the result into your .ofx file.

This number format (spaces and dot) is not available on the cloud version… but there’s 2 formats exactly alike (spaces and comma).

They are not exactly alike. One includes only a single thousands-separating space, the other includes more.

The point is that Is can’t select the highlighted number format, since it’s not shown.

This is very strange. Cloud and desktop editions are supposed to be identical in this respect. @lubos, can you explain this?

Currently, the software pulls number formats from the underlying operating system.

As for importing OFX, try to select number format which has “dot” as decimal separator. This should fix OFX importing issue.

It worked, but I don’t want to work in a foreign number format nor want to change umber format each time I need to import a bank statement. This is a feature that was working before.

1 Like

Sorry . how do i select number format which has “dot” as decimal . i dont understand

See the Guide: https://guides.manager.io/9155.