How to turn back to "Legacy Layout" all my invoices?

Hi, I noticed that invoices now have this “item column”.

I really don´t need this column. So I noticed that if I check “Legacy Layout” it goes back to the way it used to be. I even selected it on form defaults-invoices-checked “Legacy Layout” and every new invoice I make is as desired. This is how I want the invoice to be showed:

But what about every other invoice that has been created? They all went to this new mode with “item column showing” and I can´t get them to go back as “usual”. How can I fix this or is this some kind of bug due to recent updates? (I´m on Cloud Edition)

Legacy layout is only transitional field that will go away once all issues are resolved.

If you desire to hide item name, go to Inventory Item or Non-Inventory Item edit screen and check the box:


This will allow you to continue using items on invoices but their names won’t be visible on printed documents.

Is there a way to check this option all items at the time?

There is Batch update but that is a bit more technical.

See: Use Batch Create and Batch Update functions | Manager

I’m planning to implement easier way so batch update can be done directly in the program rather than going through spreadsheet.


Dear Sir
i have done this
but again Manager show too much space between the column

i think it should be auto Legacy layout setting space between column
or Add this option in all Heads

Legacy layout will soon disappear. You should not implement a plan that depends on it.

But for now .
There is too much space between two columns.
What’s solutions there .
Because it’s looking too much ackward
Please suggest Solutions

Unless the developer decides to change layout in the default theme, your only option is a custom theme. But you are getting off-topic.

1 Like

@mastertrading how did you take this screenshot? Because I’m not able to reproduce this issue. Is this screenshot from the program or from PDF generated using PDF button?

Here is my screenshot from the program:

I’ve been getting layouts more like what @mastertrading shows, with wide Item columns. This example is a screen shot from a sales invoice, as shown on the View screen:

The legacy PDF generator yields essentially the same result. And here is an example from a delivery note, which seems to be what @mastertrading’s example was from:

In your case, description is short. I see no problem with Item and Description column taking equal space if they contain equal text.

Try making description field much longer that it wraps onto the second line like in @mastertrading example (notice his descriptions are longer but I’m not sure why they wrap onto the second line as there is still plenty space left).

need to see the edit screen, he may have a new line from an import or copy

I absolutely agree with you. I was only observing that a wider-than-necessary Item column wasn’t unusual. In my example, the column narrows even before the Description becomes so long it must wrap:

@Patch’s comment about new lines is also germane. I’m actually surprised @mastertrading’s example wasn’t more evenly divided given how short the Description lines were.

@lubos I think you should add a check box to decide whether activate or deactivate this “Item Column” on printed documents. Personally I think must customers won´t care about this item code. They just wan´t to see the product name, not the code. Code is just for company purposes.

For other businesses it’s exactly the other way around. Item code is for external parties to see. Item name is internal for lookup purposes. Thoughts?


Let´s say that I wan´t to buy a Black Apple Iphone 13 Pro Max.
Let´s say that the Item code for that black iphone is “B1”

I want to see on my note that I bought a Black Iphone 13 Pro Max. Customer would not want to see on their note “B1” for $1,100 dollars. They would like to see:
iPhone 13 Pro Max Black - $1,100 dollars. Something similar happens on my business.

You could set up your inventory item like this:

  • Leave Item code empty
  • Item name is your internal name
  • Autofill - Line description is what your customer sees
  • Make sure Hide item name on printed documents is checked so your internal name doesn’t show on invoice.

Would this work?

1 Like


“Hide item name on printed documents” checked is what I need in my case. Basically I will need to update all my inventory products.

Thanks Lubos.

1 Like

@INTERC, you can complete that all at once using Batch Update.


Why not make it part of ‘Form Defaults’ and allow the user to decide what information appears on what forms. eg
Item Code & Item Name & Item Description each have their own checkbox to be included or hidden as required.

After all, I should be able to determine how I set up my invoices, receipts, payments, purchase orders etc.

This could also solve the problem of having to batch update everything to change them to the way the developer has decided we should use them now.