General ledger account loading failed

Today I wanted to get one general ledger report for a one specific account but the account number loading failed.
The full report (without filtering) is working.
Manager version 22.1.99

With kind regards

Upgrade to the latest version then try again.


Upgraded to latest version 22.3.3 but it doesn’t help

Manager server and win 64bit

(I’ll be working with Gunnar)

I cannot replicate this. Let’s try this.

Create a test cloud account here

Upload a backup of your business file and try again and let’s see what happens.


Hi @Abeiku

All working fine in the test cloud. I tried in the desktop too… no problem.

I take backup from desktop, import to our server, and … not working.
Checked all other reports, no such problem. Only in General Ledger Transactions report.

Checked in Chrome, Thunderbird, Edge … same.


Based on your tests, the problem is with your server, not the program.

1 Like

That’s possible, but it could be that the file itself is somehow corrupt.


Did you try doing it the other way around? Meaning backup the file that’s not working on the server and test it elsewhere.

Hi @Ealfardan

Now I copied one of the company’s * .manager file from server to the desktop version folder, everything is working correctly. No problem.

The problem is not with the server version of a single company, but all companies have the same problem.


Ok. Checked server log files …

when I try to select Account, the following entries appear in the server log:

/ general-ledger-transactions-form FileID = *** code 200 - OK
and the following entry:
/ autocomplete Types = *** (very long entry) 404 - Not found !!! ???

As the backup files work according to @raivodc100 analysis then it can only be a problem with the server installation. Can @raivodc100 share the server specifications including the Operating System and the Manager version that is installed.

Full error code is 404 15 0 19
And 404.15 means - Query string too long.


manager server 22.3.3
Windows Server 2012 R2 Foundation 64-bit
IIS 8.5

The specifications (free RAM for Manager Server) of the server and the Windows version are important here. SQLite is quick because it mainly tries to load into memory (RAM) but is its limitation. If you do not have enough RAM available for Manager it can not load all. The issue is with your server not Manager.

RAM 32GB, Free 19,8 GB

I think i must fix first this long query string problem… then i can check again…

The default maximum query string length in IIS is 2048 characters. When a query string is received by IIS that is longer than 2048 characters, IIS throws a 404.15 - Query String too long error .

At moment manager general ledger transactions autocomplete string more than 2500 characters long…

That seems to be the problem

Indeed, so change the IIS settings take a look at Request Limits <requestLimits> | Microsoft Docs

query string length fixed, IIS anda Manager Server restarted … but no luck

now error code is 400.0 0

That is most likely a URL syntax problem. Try to rename the account number 10. Aru… that has (kahjum) by removing the brackets. I may be that for whatever reason your server install does not like brackets.

However, your Windows Server edition (November 2013) is really old and basic support ceased in October 2018 (although being extended to October 2023). IIS 8.5 is equally old (November 2013) with support ceasing October 2023. So I would assume that proper server upgrade will eliminate most of your issues.

I agree. A server software upgrade is planned.

But anyway after fixing query string length, server shos error:

Process information:
Process ID: 8232
Process name: w3wp.exe
Account name: IIS APPPOOL\ManagerIO

Exception information:
Exception type: HttpException
Exception message: The length of the query string for this request exceeds the configured maxQueryStringLength value.
at System.Web.HttpRequest.ValidateInputIfRequiredByConfig()
at System.Web.HttpApplication.PipelineStepManager.ValidateHelper(HttpContext context)

Thread information:
Thread ID: 7
Thread account name: XXX\yyy
Is impersonating: False
Stack trace: at System.Web.HttpRequest.ValidateInputIfRequiredByConfig()
at System.Web.HttpApplication.PipelineStepManager.ValidateHelper(HttpContext context)

I’m going to dig in, maybe I’ll still be able to resolve the issue with the current server :slight_smile:
Thanks everyone!

(Unless the manager development team manages to shorten these queries :slight_smile: )