Foreign exchange gains - problem with cash accounts

Hello and thanks for reading this!
I work as an artist. I work in countries with different currencies, where I have gigs and sell CDs and DVDs. My payments are mostly in cash. In Manager, I create cash accounts for each different currency.
On the day I leave a country, I exchange all money earned (whatever currency) into Euros (base currency). In Manager, I reflect that by transfering the money from the foreign cash account to the Euro cash account, and the foreign cash account ends up empty.
The only exchange rate that is relevant, in this case, is the rate I get payed on the day I leave the country and exchange the cash earned. As far as I can see, I have no gain or loss on foreign currency. So how do I get rid of the “Foreign exchange gains (losses)” that Manager presents, with seemingly “fictional” gains or losses - which I don’t even understand where they come from? Am I missing something, or doing something wrong?
Thank you!

Because you have transferred money between accounts that are denominated in different currencies, an exchange rate must be involved. When you enter the converted Euro amount directly, you’ve incurred a currency gain or loss unless, by pure happenstance, the exchange rate matches what Manager was using. To remedy this, you should go to Settings => Exchange Rates and set a new rate whenever you convert.

Sorry, I forgot to mention: I have set exchange rates - exactly the ones I received when converting. Still, whenever I input expenses payed from the foreign cash account, Manager introduces its own exchange rates and calculates gains or losses, which are marginal (usually just a few cents or so) - but this happens for every single day in which the foreign cash account is active, so it adds up. I’m uploading a screenshot ->
Is there a way to bypass Managers own exchange rates, and use only the one that’s actually relevant - the one I got when I changed my money? That’s the 1,1015, all other rates are generated by Manager and I would like to know how to control them.

As a suggestion, when you enter an exchange rate use a date prior to the transactions.
If you arrive in a country on the 2nd and leave on the 10th. In Manager, use the 2nd as the date but the rate as applicable on the 10th. This way, if I am understanding it correctly, all transactions after the 2nd should use that rate until another rate is added… (toes crossed)

Oops, I just realised that you can’t on the 2nd predict a rate for the 10th. The above would only work if you entered the transactions after setting the rate on the 10th.

So if transactions are entered on the run, set an approx. rate on the 2nd, then edit it on the 10th. Once again, if I am understanding it correctly, this should (?) change the rate for all transactions after the 2nd. I don’t believe you need to set a rate per day. The Guides are silent in this area.

As to your question, where does Manager get its rates from - no idea
Might have to go and do some exchange rate modelling.

Thanks Brucanna!
Sadly enough, your solution doesn’t work. Even if I input the same exchange rate every single day, Manager still uses its “own” rate on all expenses made in cash. See screenshot:


As you see, every single day there is a small discrepancy between my own exchange rate and the one Manager calculates itself - and this adds up. As you can see, there are 4 different exchange rates in play:

The last one, in blue - 1,1015 - is the one I entered in the settings, and the one I got in the real world. The other ones - 1,1011 - 1,1013 - 1,1028 - are coming from I don’t know where and seem to be introducing rounding errors. How do I get rid of them, or control them?

That’s a question for @lubos

Thanks @Brucanna!
Hi @lubos - do you know how to turn off the calculation of Foreign Exchange Gains, when those are not relevant to my business because all I have is:

  1. foreign cash that enters on a daily basis, while I am in a country;
  2. some of that cash is spent on a daily basis, while I stay in that country;
  3. all remaining foreign cash is exchanged on the day I leave the country, at a single rate, emptying the foreign cash account.
    Or am I missing something?

@Mendel, go to Settings tab, then Exchange Rates where you can set what exchange rate Manager should be using.

@Mendel has set the exchange rate to exactly what was obtained. See post #3. But the program seems to ignore those settings and uses its own.

@Mendel, this may be too obvious, but are you sure you are clicking Update when you enter an exchange rate?

OK then, can you post screenshot how of those payments with those different exchange rates were posted? What I mean is screenshot of edit screen on one of those payments.

@lubos
Hi there - I was ill for a few days. Sorry. But I’m back now.
It looks like the “lost” cents are a result of rounding, where Manager seems to “prefer” rates that, upon dividing a given amount, give a round number of cents in the other currency. So it replaces the rate I gave in the settings with the closest possible rate that gives a whole-cent result. Those roundings add up during a day, giving cents of difference.

I’m posting a few screenshots:

  1. Payment made in “foreign” cash (edit screen)
  2. Same date: sell in foreign cash (edit screen)
  3. Same date: overview of “Foreign exchange Gains (Losses)” - showing an exchange rate of 1,1011 for payment (1) and 1,1013 for receipt (2) - instead of 1,1015.

Did your points 3 & 4 meant to have screenshots posted

@Brucanna The system blocked the other images (only 3 were allowed). I’ve corrected it now.

@lubos
This is a continuation of my post above (1 hour ago):
To counterbalance the rounding errors I mentioned, I now added more decimals behind the komma in the Exchange Rate Settings (1,1015 became 1,1015456)
Funnily enough, the rounding seems to be done differently in different places: in the Single Day Overview, the loss is sometimes shown as 0,00 , but it still shows up as 0,01 in the Summary Overview.
See those 2 sceenshots:

@Mendel, this looks like a bug. Any chance you could send me your accounting file to lubos@manager.io ? I will look at these rounding issues.

This is bothering me too…
all finances are out due to this auto calculation of exchange rate. Have you found a solution as I cannot get my accounts correct as I also deal with 2 to 3 currencies…