DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

Etc/rc.local


#1

I have update the /etc/rc.local with the following

/usr/bin/mono /home/sean/ManagerServer.exe -port 8080 >>/dev/null 2>&1 &

Manager does not start on reboot of Ubuntu 14.04


#2

What happens when you launch

/usr/bin/mono /home/sean/ManagerServer.exe -port 8080

Do you get server started on port 8080?


#3

/usr/bin/mono /home/sean/ManagerServer.exe -port 8080

starts the server on port 8080 after about 2-3 seconds

Also I am using a Dell E6420 laptop as my server running ubuntu 14.04


#4

Then it’s something wrong during booting.

What’s in your /etc/rc.local ? Is it exactly this?

#!/bin/sh -e
/usr/bin/mono /home/sean/ManagerServer.exe -port 8080 >>/dev/null 2>&1 &
exit 0

also, make sure to give etc/rc.local correct permissions by launching:

chmod +x /etc/rc.local

#5

Applied chmod +x /etc/rc.local

/etc/rc.local contains

#!/bin/sh -e
/usr/bin/mono /home/sean/ManagerServer.exe -port 8080 >>/dev/null 2>&1 &
exit 0

when I run
mono ManagerServer.exe -port 80

Syntax:

    mono ManagerServer.exe [options]

Options:

    -port [number]     Set port on which HTTP server should listen on.
    -path [directory]  Set directory where Manager should look for data.

Examples:

    mono ManagerServer.exe
    mono ManagerServer.exe -port 80
    mono ManagerServer.exe -port 80 -path "/home/sean/.local/share/Manager"


[7:46:10 PM] HTTP server listening on port 8080

^C

the system hangs and I have to press CTRL+C


#6

:~$ mono --version
Mono JIT compiler version 4.0.4 (Stable 4.0.4.1/5ab4c0d Tue Aug 25 23:11:51 UTC 2015)
Copyright © 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
TLS: __thread
SIGSEGV: altstack
Notifications: epoll
Architecture: amd64
Disabled: none
Misc: softdebug
LLVM: supported, not enabled.
GC: sgen


#7

unless I manually launch ManagerServer , I am unable to use manager


#8

By the look of it, Manager Server is working on your Ubuntu. You need to find out why /etc/rc.local is not being called during boot time. Perhaps Ubuntu forums will be better at finding out what’s the problem.