Emailing Error

Having this error when sending email from manager with a receipt attachment:

System.Net.Mail.SmtpException: System.Net.Mail.SmtpException: Syntax error, command unrecognized. The server response was: 5.7.0 Mailgun is not loving your login or password
at System.Net.Mail.RecipientCommand.CheckResponse(SmtpStatusCode statusCode, String response)
at System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, Boolean allowUnicode, SmtpFailedRecipientException& exception)
at System.Net.Mail.SmtpClient.Send(MailMessage message)
at ManagerServer.HttpHandlers.Businesses.Business.Email.Post()

@lubos kindly assist. Am using server edition version 19.6.64 on windows 8.1. I’ve tried doing same on desktop edition same version, the problem still exists. Thank you.

3 Likes

I am also receiving this error, on Cloud edition. I tried emailing statements. After receiving error message, I attempted several test emails to different addresses, and using different customer statements. It doesn’t appear to be a problem with my own email or my own network connection.

Please advise.
Thank you,

Liz

2 Likes

Our email provider Mailgun has shut down our SMTP account without notice which means emails from Manager only work for those who have set up custom SMTP server.

I’m currently trying to resolve this issue with Mailgun.

3 Likes

O ok. Thank you and keep us updated when it’s resolved.

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

Can you tell us where to find more details on setting up custom SMTP? I have the same exact settings in our other software and verified the password but when I test the settings in Manager, I only get a message saying message could not be sent. It doesn’t give me any direction as to what errored out.

Any help here is greatly appreciated as it is the first of the month and all of my recurring monthly invoices need to be sent out.

Kindly follow link for guide https://www.manager.io/guides/10643

However, I got some challenges while setting up custom smtp using my gmail account. I will share for all to benefit. After I had filled in all the details: host ie smtp.gmail.com and port 587 and typed my email address and password, I still could not get the test successful. After some research I got to know some security settings in Gmail was not allowing an unknown app(manager) to access my gmail account. So I set my Gmail account to accept connection from unknown Apps and that worked. Now I am able to send emails through manager.

It would be helpfull if you can give us the emailaddress you use for sending the invoices.
If you use Gmail you also may have to change settings in your Gmail account.
(You have to activate Two Step Verification (https://www.google.com/landing/2step/) in order to make it possible to allow an unkown app to access your Gmail account).
If you use your own emailaddress you must know the SMTP server 's name and portnumber. Often to be found when you google “SMTP server” + [the name of your provider].

I used my own Gmail address and I gave the smtp host/server name and port number in my previous post.

I’m closing this topic. There is new one.