Data cut off in PDF for Arabic

Dears,
I have an issue when using print to get PDF in Arabic, the data on the right side disappear and then also when I choose to save location and press ok, the all manager app closes.

but when trying to print PDF in English, everything is good

First of all, that’s an unrelated subject and so I flagged your post to be split by mods.

You’re using a custom theme. So:

  1. Data labels change according to the language selected and it looks like you’ve written some conditional logic on English labels. That’s why those fields don’t appear in Arabic.

  2. There appears to be a bug with your theme. You needs to debug it yourself or share the code so other users can see where it went wrong.

1 Like

I didn’t use a custom theme

it is (Plain) for Arabic & English

How come the side boarders of the main table are missing?
:thinking:

1 Like

only in Arabic

This is one of the reasons why @Lubos no longer supports the in-built PDF generator. You are advised to use the print to PDF option it will render both Arabic and English versions well. Disadvantage is that you have to email them with your email application rather than Manager.

I think the problem is the length of your lines in your business details. It’s hard to tell what is there, because you’ve shown screen shots of your print preview instead of the result. But it looks like you may have duplicated both English and Arabic in your business name. The result is that you’ve exceeded the limits of space allocated.

Try shortening the name of your business to see if that fixes the problem.

1 Like

Still the side border is missing in Arabic only

What do you mean by “still?” Does that mean you shortened the business name? You really need to post screen shots when discussing display issues—and shots of the actual transactions, not the print preview.

or split it over two lines using html break marker < br > (without the spaces)

Here is 2 example one for Arabic and the other for English.
both are after shortening the name

It looks like all your columns are present on screen. But many of your lines still look longer than the program will accommodate. Try shortening them more.

Also, what are your print previews showing? How were those images generated?

Now it’s clear that this is a printing issue. Idk about Mac but in Windows there’s a scaling option to fit the entire width of content to the page.

If you can’t find that, then the best option could be this:

Your customer block should be:

الاسم بالعربي
English Name
Address 1
Address 2