DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

Custom fields date format not working correctly


#1

Hi custom_fields date type format does not follow date format in settings.
@lubos


Wrong date format when importing qif
#2

I can reproduce this. For example, this preference:

33 PM

shows dates correctly on entry forms:

57 PM

but produces this on a viewed transaction:

21 PM


Delivery Date on Purchase Orders
#3

Fixed in the latest version (17.12.68)


#4

I just installed v17.12.71. This problem either was not fixed or has reappeared. I checked both existing and new transactions, in particular purchase orders and employees. The problem arises both in column listings and on finished documents. It does not resolve if the date format is changed under Preferences.


#5

Yes a problem - will be watching this topic hopefully someone will post once resolved.

Guys hopefully something can be done quickly … We are receiving some heat on this case.


#6

FYI - Just updated Manager and issue is still active.


#7

Should be fixed completely in the latest version (17.12.74)


#8

Tremendous - Fixed - Thank you very much.


#9

@lubos You fixed it on the invoice but not in the grid view of invoices (Show custom field as a column) and it displays wrong


#10

The same is true in other tab listings, for example, under Purchase Orders tab.


#11

Somehow this issue has not come back to haunt my team after the update we applied 2 days ago. I will wait until you guys confirm OK before we apply any new update going forward.


#12

Perhaps this is specific to an operating system. I am using macOS. @Marteinn_Brynjolfur, @compuit, what are you using?


#13

Our Manager host is Ubuntu Server


#14

Check again the latest version (18.1.4). This one will show custom fields correctly in tables if format is set to “Date”. Also sorting the tables by clicking on column header will sort the rows by date.