Cannot delete Division in Settings

Prior to introduction to Projects, I used to use Divisions for project based calculations.

Today I created projects, assigned all transactions and inventory items to their projects, but also changed previous division to the a different ones, that actually make sense now. This means there is no trace of divisions I created for projects, and even profit and loss statements for those Divisions show all zeroes now.

The problem is that I cannot delete divisions from Settings > Divisions. Even though I changed Inventory items to new division, it seems like there is some kind of link still to old Division for these items. Every transaction for purchase invoice for items previously connected to old Division now show up when I try to delete it. When I go to Edit, there is now way to set division on project since it’s Item being acquired, and those fields do not show. I can only set item division inside Inventory items themselves.

If you cannot delete a division, and Manager is showing you a list of affected transactions, then there are still references. Those could be from several sources. So, you need to choose one such transaction and show Edit screens of everything related to it: invoices, payments, receipts, inventory items, etc. Sometimes, there is a reference to a reference to a reference, if you understand my meaning.

I know what you mean, and I think I followed the path

Trying to delete division, and I get the message:

Then I try to edit first item, and I cannot change division there as it is purchase invoice for an inventory item:

Then I go to the inventory item and edit it and, as you can see, division has been already changed:

I don’t know if there could be any other trace of division for this transaction.

You need to delete the division code on the inventory item

I did. Current division is what it should be. Previous one was “Jugopetrol”. I just now tried removing division from inventory item all together, and still this transaction shows in the list when I try to delete division.

You can’t delete divisions if you are still using them

It is not clear what you are trying to delete

Hm, sorry if I was unclear. I will try to explain better.

I used to have a division “Jugopetrol” which was actually a project. When projects were introduced, I created “Jugopetrol” project and marked related transactions to the project. Checked project Income, Cost and profit and everything was fine.

Now, it was time to change division for those transactions from “Jugopetrol” to the actual company division. I traced all transactions (for this project it was simples as there were only a few transactions). There is no trace of “Jugopetrol” division in any of those transactions and I still cannot delete the division.

To me it seems that there is some kind of link staying to the Inventory items, even though I changed division inside the inventory item. Direct cost and income invoices were unlinked.

You said you moved from using divisions to using projects

But your inventory item is still affected to a division. It should be blank

Divisions and projects are completely different

What do you mean by “actual company division” ?
there is no such thing in Manager

Inside inventory item selected division is “Izvodjenje radova” which is NOT “Jugopetrol” division which I am trying to delete. I also tried leaving division BLANK, updating inventory item, and still it shows up when I try to delete “Jugopetrol” division.

I know division and project are completely different. Actual company division means that I have a division inside my company that owns this project. It is not a Manager feature.

By any chance have set a Lock Date?

Nope. I had to remove it when I did all of the edits

Now that you have changed the division in the inventory item, go back to the transaction and on the affected line(s) change the item to a different item and then change it back again, See if this works.

If that does not work go back to the transaction add a new line select the inventory item, and then delete the original line.

First suggestion worked. Cannot believe I haven’t tried that yet… I tried previously to just reselect same item and that did not work.

Thanks for your help!