Bank Statement Import problem

I wanted to try the cloud edition but facing issues in importing statement.
When I select the csv file for import, it shows the right balance as it should be.

But after I import it, all the entries are done as amount paid and hence the closing balance also changes

The balance error is due to all the entries being done as amount paid.

Also, I tried it with the offline version with the same csv file and the import works just fine there. Not able to understand the problem.

The cloud and desktop editions use exactly the same code to import bank statements. The only difference between the two is the cloud edition’s multi-user capability. Are you certain your desktop edition is the same version as the cloud edition? If not, update the desktop and try this again. (Use Bulk Delete to get rid of the imported transactions first.

Also, I hope you realize you cannot perform this experiment using the same business data file for both versions. That will result in duplication.

The problem is not the difference of versions which is the same in both. The problem is with import of transactions in the cloud version. It imports all transactions as ‘Amount Paid’. I think the cloud uses the latest version updates so unable to understand why it is occurring.

OK. So you have eliminated one possible source of the problem.

The next thing to do is to see if your bank offers exports in any format besides CSV. CSV is the most problematic type of import file. If your bank offers any other choice , try it.

Another thing you could try is to repeat the experiment to make sure that the problem really persists.

Already tried it several times. One thing to note here is in the pre-import stage (confirmation stage), it shows the right balance but after import it shows the wrong one. I tried it with qif file as well and the same thing is happening. On the desktop version it works fine, but not on the cloud one.

One more thing which I just tried which may be important is - The import is working fine on Mac Desktop Edition but on the Windows desktop edition I am facing the same issue as the cloud edition.

That explains why I can’t duplicate this problem. I will put this into the bugs category.

Also to add to the finding, I just noticed that after import, even if the description shows as income, the amount is shown in amount paid.

I think this will come down to CSV file and what exactly is in it.

Would you be able to send me CSV file you are trying to import to ? I will have a look.

Done. Have sent the qif file as well.
Thank you.

I created a new company and imported the file and it worked fine. Strange why it did not in the first one. Unable to find it yet to replicate it in the new company. Sorry to bother and Thank you for the prompt response.