Automated payments have caused overpayments?

I’ve just updated manager to the latest version 15.7.30 but on doing so a heap load of automated customer payments have appeared causing overpayments? how can i remove them all?

Manager has no ability to make automated payments. What you may be referring to is automatic allocation of customer credits to new sales invoices. If so, your experience suggests you may have been incorrectly entering something in the past, which had the effect of building up customer credits you were not aware of.

Can you provide more details about exactly what you have done and what you are seeing?

Thanks Tut, sorry was being brief in my message , the software isn’t actually making payments but is creating an automation for credit and overpayment.

I have been using the software for quite sometime now, i’m on my 2nd round of corporation tax and haven’t had any problems so far, it was only when i updated the software all of these payments came though.

I manually input my sales invoice, then when a payment is made, link the invoice to the bank statement using “accounts receivable” if the payment is for multiple invoices… i add lines to cover all.

On this update i now have over 20 notes showing in customer credit that state…
“Automatic payment using available credit” then straight after that note "Overpayment - Sales Invoice #"
These are for invoices that have already been allocated and squared away?

The edit key is greyed out so they cannot be deleted

Any ideas?

Is there a back route way in so i can delete these entries or a way to revert back to an older copy of manager?
I tried to reinstall an older copy but get an error?

Any help is super appreciated, my return is due in 2 days and this has completely bogused my whole accounts for the past 3 years 8-/

What you describe is exactly what is supposed to happen when customer credits exist. Because you designated a specific invoice under Accounts receivable, it recorded the rest of the payment as an overpayment and allocated the balance to Customer credits. Once those customer credits are there, Manager tries to allocate them to the next invoice, and the next.

I don’t know when you last updated your software, but things have changed a lot in the last year. Entries made earlier as journal entries have been transferred to Bank Accounts and Cash Accounts. Rest assured, though, nothing was lost.

You don’t make it clear what you are looking at when you see the entries of automatic allocation and overpayment. Can you clarify that?

The important thing is whether the sales invoices show as paid in full and whether customer accounts seem correct. I wouldn’t get hung up in all the automatically generated entries in the control accounts. And you definitely don’t want to delete them. Try creating some customer statements for all transactions to see how things look there.

As a last note (for this round of our exchange), I am confident the software update didn’t change your accounting. You may be seeing things you didn’t formerly look at (but which were there) or you may have inadvertently changed something about your displays, such as the Summary period, or toggled from accrual to cash basis, or similar. But unless you were doing things incorrectly all along, your data is present and uncorrupted.

Final random thought: your Suspense account balance should be zero. If not, you were entering unbalanced transactions.

Wow, it would appear that perhaps it has been a year since i updated the software.
since everything was working fine i didn’t have cause to update anything.

The problem i have is the automation isn’t correct and is updating unpaid invoices.

On the previous version, When i import a bank statement, i then allocate the payment through the bank statement to the specific invoice.
Which is important as a lot of my clients are overseas and the bank statements do not always show invoice numbers or reference.

What has happened on this update is all of the those payments i have already allocated have been duplicated only they are not showing in my bank balance just showing as customer credits which are now automatically reducing or clearing unpaid invoices and cannot be edited? On the Customer statements the payments that were allocated on bulk are not showing with the corresponding invoice but are now separated?

One customer for example is showing as having €11,000 as credit even though the start balance is 0 and all invoices have been paid correctly and inputted previously.

I’ve checked the screen grabs of my previous years accounting and the tab pane is set the same on the summary page.

I’ve attached a screen grab of some of the entries here to illustrate.

Is there a simple workaround to undo this or to re-allocate?

Thanks again for any help


I cannot tell what your two screen shots show, because you’ve only captured part of the displays. Can you explain what I am looking at? The two screen shots certainly do not correlate with one another.

I suspect the second one is a portion of a customer statement showing all transactions. If so, it seems to show a customer that pays somewhat irregularly, but does periodically bring its balance owed down to zero. Judging from the dates, some payments cover more than one sales invoice, but not necessarily the largest or oldest. Manager’s automatic credit allocations could be confusing in such a situation. But the arithmetic will not be wrong.

While I am clueless what your first screen shot shows, that may be because incorrect entry practices are filling data into columns that should have nothing in them. One thing Manager does is hide columns with no entries. So as I search for a display matching yours, I may be on a fruitless quest, because you may have incorrect entries adding extra columns. I hope that makes sense.

This also suggests what might be wrong. If you are importing bank statements, you should not also be making entries to record payment. That results in duplication. And, in fact, whatever your first screen shot is showing, it does seem to contain duplicate entries. Since I don’t know what it is, though, I can’t tell how they got there.

Based on the frequency of entry shown by these screen shots, you don’t seem to have many entries per month. So I would recommend against automatic bank statement importation. I think it has the potential to cause more problems than it solves unless you’re doing dozens of transactions per day. (There have been many recent changes related to statement importation, as you might notice from the Changelog at http://changelog.manager.io. The Changelog also shows just how rapidly the program is evolving.)

The two screen shots are exerts from 1st “customer credit” and 2nd “customer statement” as mentioned, This is the only place the “credits and overpayments” appear.

The 1st screenshot, is an exert from the customer credit section i am referring to, project names and client have been blurred for my clients privacy. On the release of manager i was using there was no alternative to manual input from a bank statement? I do not create receipts for payments only connect them to the invoices via the bank statement. As most of my customers are based overseas using different currencies they do not automatically link, also, multiple invoices paid in bulk had to be allocated via the bank statements to reconnect with their corresponding invoices. I am also clueless as to how else i should have been allocating these payments?

My client list transactions are infrequent but my bank statements are extensive with multiple payments to and from multiple suppliers everyday.

The duplicate entries on the customer statement are the issue i am referring to that have not been inputed manually, and does not appear on my bank statement, there is only the one entry which corresponds to the invoices allocated.

The figures in customer credit, have appeared but do not seem to exist anywhere, i cannot delete them or find their source.

You are correct that not always the invoices are paid in order which i image is the case with numerous business whom are involved in multiple projects with the same customer? I need to keep track of which invoices have been paid not have manager automatically decide which has been paid.

1 Like

@jax, thank you for the additional information. I do not understand what is happening, because your Customer credits display looks different from mine for some reason. But I still suspect the problem comes from importing your bank statements.

I suggest you contact @lubos directly and ask for assistance. He may suggest sending in your accounting file or arranging a team viewer session.

First of all, what system is doing is a good thing. At least you have spotted a problem with your accounts.

So let’s discuss invoice #15471 which was for 1,200 EUR.

Based on the screenshot, it looks like you have bank account in GBP and when you received 1,200 GBP, it was converted to 1,484.76 EUR. You then allocated this amount against invoice #15471 thus overpayment of 204.76 EUR was posted to customer credit account. This is correct.

You claim there should be no overpayment. Why did customer pay 1,200 GBP then? Could it be that bank account should be denominated in EUR instead?

Anyway, can you shed some light on this 1,200 GBP received on 03/06/2015 for invoice #15471?

Thanks Lubos,
A Happy New year to you too -

I’ve spent a lot of time going over this over the break and it appears that when i updated, the software made 1 duplicate entry for each of my customers, this has been easily rectified by deleting the last payment.

However, i have unearthed a further problem with the automated system.

The payment you refer to above was the only overpayment received however this payment was rectified on a further invoice.

The problem lies as described below:-

I am a british company accounting in GBP, I have 1 client based out of New York that i invoice in GBP. However on certain jobs our sub client needs to be invoiced in EUROS. The software when i first started would only allow me to invoice each customer in 1 currency. I therefore created 2 customer profiles. 1 for GBP and 1 for EURO.

When the client pays me, they sometimes bulk the invoices together. So i would perhaps have 1 invoice from the euro account and 1 from the GBP grouped in together in the same payment.

So the problem i have is the software allocating auto payments to the wrong invoices.
Is there a way to remove this auto allocation feature? Or is there another way to avoid this?

Many Thanks!

If you have one customer who you invoice in two currencies, you need to create this customer twice. So customer will have two accounts with you, one in GBP and one in EURO. There is no other way.

Customer can still pay you for two invoices, one in GBP and other in EURO. You just have to split the received money across both customers or specific invoices.

Thanks, that is what I have been doing as described above.

The problem is the automatic allocation of payments to invoices. Is there a way to turn this off?

Again as I mentioned earlier, the invoices are not paid in order , I do not want the software automatically decide where to allocate funds. Especially across the 2 separate customer accounts.

If you want to “turn off” automatic allocation, then don’t match your payments against Customer credits account.

Select Accounts receivable, then select specific sales invoice you are allocating the amount for.

Yes, it’s more work but if you don’t automatic allocation, you need to be explicit what specific invoices you are matching.

Normally, I use the “Receive Money” button and allocate the payment to the correct account and invoice but it seems as though I must have slipped up on a few occasions and handled it wrongly as some transactions have “Automatic Payment” shown against some invoices.

(I don’t download and use bank statements from the bank with all entries entered manually.)

I would prefer that the “Automatic Allocation” feature was turned off but can’t find where to turn it off
(I’m currently using Version 16.1.16)

@scannerangelaust by turning off automatic credit allocation you are not solving anything. You are just hiding the problem.

Some invoices will be still overpaid. At least with automatic credit allocation, those overpayments will be applied to other invoices.

The question is, are you able to identify entries which triggered automatic credit allocation? Perhaps I could add a report which would show list of those problematic entries. Then you can fix them until automatic credit allocation is not triggered.

That sounds like a great plan, if you are willing and able to help.

I’ve now also realised that I have Auto Payments going in to Accounts Payable too so I must be doing something drastically wrong.

I was also about to prepare my BAS for December and it appears as though the tax that I’ve paid on imports hasn’t been included in the GST paid at 1B on the report.

If I send a copy of the account file, when you have time, could you please have a look and let me know where I’m going wrong ?

Could you upgrade to the latest version? I made some improvements to tax reports and if you are using GST on imports tax code, you should be able to see it Tax Audit and also in Tax Summary report which in turn is used to put figures on BAS calculation worksheet.