API with Error 401

Hi,

I need some support for the API authentication, i have try the way from article Error 401 but i’m still facing the same issue.

I have try to change all the way i can but still i’m getting the error 401.

  1. change the username and password to very simple format
  2. try to use the username password with >> username:password@.manager.io/api//XXX-XXX-XXX
  3. use basic authentication with few format
    • “username”|“password”
    • ‘username’|‘Password’
    • username|password
  4. to ensure the format i’m putting is exactly correct, i’m also testing on API testing website

Please anyone can help on this?

wanna to use this to setup a automate process. for the automate process, i’m follow this article Automate with Zaiper

Hi @lubos, sorry to tag you out here, but i saw most of the article you have actually support for the answer, can you also share your idea here. thanks a lot.
As i desperately want to find out the answer and setup the automation from 3rd party software to manager.io. I’m currently using the serve edition.

The issue as I see it – and I am guessing based on my trial and error experience with manager api, is that authenticating using http request is kind of random since the server does some kind of a hiccup. My success rate with http authentication is 50:50.

What I do is authenticate with my browser and then take the authentication key as well as the cookie instead of the username and password.

I hope this helps.

Hi @Ealfardan, can you share with me what do you mean you authenticate with your browser and take the authentication key ya?

Login to your api page in your browser:

Then open developer tools in your browser, select Network and refresh (you can skip the refresh if you start the developer tools before you login).
You will get all the headers used for that session like so:

Hi @Ealfardan,
Have try the solution but still no luck. Is there any places that i need to turn on the authorization?

The api is working fine, I tried posting this request in cmd and this is the result:

In fact I tried user:password@site in cmd and it works fine as well.

When I use the same server and headers in reqbin I get the same error you get.

Idk what is the exact problem here, but I guess reqbin in trying to authenticate at “x.manager.io/” level when manager actually requires authentication at “x.manager.io/api/” level; and when you use the key+cookie, I guess reqbin has no access to your cookies and therefore fails. I could be wrong tho, @lubos might provide more help on this.

Anyway, I tried both the curl and python codes the site generates and they both seem correct, so how about you skip testing on reqbin and see if it works or not outside reqbin?

Hi @lubos,
can you help on this?

@DnD_IT_Solution, this forum is for discussion of issues with Manager, not instruction or troubleshooting on other programs, software you are writing, or interfaces with third-party systems. Those are your responsibility. I am closing this topic.