Tax not labeled on invoice

In the latest version, at the bottom where the totals are the line for sales tax is not labeled. I just get a number with nothing to the left of it, leaving my customers to infer that this number is sales tax and not some random fee that I just added on.

Additionally, as a second problem; for sales quotes what ever price I hand out seems to be tax inclusive. The “amounts are tax inclusive” box is not checked however all quotes say that the price “Includes PA State Sales Tax”. This has been an issue in both the current and previous versions.

Just noticed that my quotes are also missing the “PA State Sales Tax” label, currently they just say “Includes”…

I just updated to the latest version 20 minutes ago, haven’t updated in approximately 2 months.

Can you go to Settings, then Tax Codes and edit your PA State Sales Tax? What is entered in Component Name field?

Have a look at Manager Cloud how custom tax codes need to be configured (it’s really the same concept as in Quickbooks)

Regarding the Amounts are tax inclusive checkbox, if the box is not checked, taxes should be added on top of your amounts which they do when I’m testing the latest version. Can you post some screenshots demonstrating this issue?

Perfect, that fixed the first issue. Here is a screenshot of what I am dealing with on the sales quotes.

Any suggestions? As it is now I am stuck crossing out the “Includes” and writing a second total underneath the tax… unprofessional and annoying.