Tax inclusive vs tax exclusive amounts

What on earth is going on?
The guide says “If you are charging tax, by default unit prices on sales invoices are
treated as tax exclusive. You can make unit prices tax-inclusive in
top-right corner when creating or editing invoice.”

HELLO? There is NOTHING in the top-right corner when creating or editing invoice. NOTHING. What software is this guide actually referring to, because for some reason it’s not Manager.

I want my invoices to all be 10% tax inclusive listed as “GST”. The only option I have is adding witholding tax to the entire invoice.

And can the invoice template be edited so it reads “Tax Invoice” instead of "Invoice’?

Actually OK. I’ve worked out I need to use the templates.
But how does all the tax stuff work? I can follow HTML but I can’t follow the code on the template.
When I hit preview on a test invoice that has witholding tax none of the witholding tax shows up on the invoice at all???

Why is there no information about any of this in the Guides considering how much of the bleeding obvous IS actually explained?

I have created a new tax code for Australian GST, but now it’s not showing up anywhere on my custom invoice.

Does anything here work?

Alright I seem to have fixed it myself.

Actually no. It’s printing Total and Subtotal in the wrong order and not showing GST against each line item.

What is the field name for the line item price excluding tax?

Why is there no list of field names available?

List of variables is here: http://guides.manager.io/businesses/settings/view-templates/sales-invoice-variables

But what exactly is the issue you have with in-built template?

It is showing the subtotal instead of the total so the entire system is going to be stuffed because customers aren’t going to be charged the rght amount?
The Tax Code for Australian GST seems to be set up wrong. Total should equal subtotal plus GST

Show the screenshot what you see. Don’t use custom HTML template when taking the screenshot.

OK GST seems to be behaving now. But what’s this weird text appearing in the Tax:
This is what I get when using {line.tax}

This is what I get when using
{{ line.tax | money_without_currency }}<
“Liquid error: failed to convert parameters”

line.tax variable is an object. Not a number, you can’t apply money_without_currency filter on it.

If you are looking for tax amount, then you need to use variable line.tax.amount

But why do you need to use custom HTML? What are you trying to accomplish?

OK thanks. I’m creating a custom template because the existing template didn’t show GST on line items.

Can you advise why the line item names aren’t showing up now? The field in the template is “{{ line.item.name }}”
I can;t find anywhere to input this - only the description?

OK I’ve worked it out. needed to set up the Sales Invoice Items first.

In Australia, it’s not required to show GST amount per line item. That’s why default template doesn’t do it.