'Show custom field as column' option not working

see below

shows up as a single field rather than a column. just updated to the latest version and still not working.

Set as a column is used to show the custom field on the transactions list and not as column on the form itself.
what you are trying to do is possible by creating a line item custom field.
read the guides section regarding custom fields.

Okay, thank you, to display it as a line item you used to have a checkbox. On observation that that option had disappeared, I assumed that the name had changed in the update. After reading the guides I have worked it out.