Manager won't start with SQLite.SQLiteConnection exception

Fantastic! Will you update this post with progress or will it be posted somewhere else?

Hi Lubos -

I wasn’t sure if you saw my reply and thought I would check back on this. When you do get this fixed, will you post about it here or somewhere else? I want to make sure I know when it is fixed and want to know where to check for updates.

Thanks!

Zak

Latest version is now listed on the downloads page: Download | Manager.

Thanks Tut. I wasn’t sure if the fix for the x86 computers would be posted there also. What is there now is for x64 only. Are you saying that when Lobos fixes the issue, that fixed download will be on that page, too?

No, I am not saying that, because I don’t know. I was just answering your question on where to check for updates.

Hi - I am planning changing to a 64 bit OS to be able to use the most updated Manager since this issue looks like it may not be resolvable. Is there any problems with opening a file created with a previous version (16.12.1)? Any steps I need to be aware of or changes I will need to make?

Thanks!

Just back up the business from the old installation, install the program on the new installation, and add the business from the backup.

Hello Lubus,

It appears to me that I’ve a similar issue shown in this photo. I’m installing ManagerServer on Ubuntu Server 18, I tried to installed on Desktop Ubuntu and it works fine. I checked SQL files including libe_sqlite3.so are included in the manager installation but the issue still exits. help here would be appreciated.

Unless you provide more information about the platform, OS version, what steps you took (as outlined in the installation guide) no one can really offer help other than in a very general way

If you are installing a Server version, you are assumed to have the technical know-how on how to manage the installation, operation and backup of the system

Did you follow these instructions: Ubuntu | Manager?

Hi Joe,

The OS is Ubuntu Server 18.04.4 LTS on Raspberry Pi 4. Followed the steps precisely in installing prerequisites, downloading Manager Server and enabling it as a service. The issue is when I call the website from the local network on the default port I get the provided internal error every time I refresh the page.

Yeah followed them, in installing the dependencies, the manager server and enabled the service. and when I refresh the page from the local network i get the error

Are you saying that you get the proper page and that if you then refresh the page it goes wrong
or that when you enter the URL code it give the message?

While it is not part of the forum to debug your server installation, if you want help you probably need to be much more specific about what you have done and show more screen shots of the results.

No I don’t get the proper page in the first place. It provides me the same error every time, regardless if it is the initial program start or a refresh

I am not competent to diagnose your setup, but it seems like the SQL Lite installation is not correct and/or some prerequisite is missing

It maybe that the Raspberry Pi is not a suitable platform

Also, I would not be sure that having a server and a desktop on same system would work

Search the form for “raspberry pi.” There have been several discussions about using that platform.

@monshar libe_sqlite3.so is native 64-bit library so currently when it comes to Linux, Manager Server requires 64-bit operating system to run on. Is your OS 64-bit?

1 Like

Hi Lubos,

It doesn’t seem that my system architecture is the usual 64-bit, the Raspberry Pi CPU adopts aarch64 instead. Shall I expect an update for it?

You mean arm64? In that case you will need libe_sqlite3.so compiled for arm64.

The solution is discussed in this topic

Try libe_sqlite3.so from this package:

https://www.nuget.org/api/v2/package/SQLitePCLRaw.lib.e_sqlite3.linux/1.1.14

It will download .nupkg file which you just rename to .zip and unpack.

Then take libe_sqlite3.so from runtimes\linux-arm64 folder. By default, Manager Server is using libe_sqlite3.so from runtimes\linux-x64 folder.

1 Like

Thank you ! it worked