GST on imports


It seems there’s an error with GST on imports in the suppliers invoice…
I found this error today. All my previous suppliers invoices which have gst in imports now have an errors that the gst is still payable and overdue. Can you fix this asap please? Thanks.

See below screen shots.

All the balance due that are now overdue are actually gst on imports that should be in the invoice amount already and all paid. It seems the system counts the gst twice.

1 Like

Your partial screenshots are not of much use - you need to show the full screen

Also show the edit screen for transactions as well as the view screen

I can assure you that Manager handles tax correctly - if there is an error it is because you have setup somrthing incorrectly or entered transactions incorrectly

Hi Joe,

You can clearly see the error here in my first screen shot.
Total figures shows 1652.30 and a payment of 1652.30 was made on 21/6/21. Since now the invoice was paid in full and had no problem but today I saw there are lots of previous invoices that I’ve paid long ago now overdue.
The 535.36 is gst on imports and is shown as balance due. This shouldn’t be shown here as full payment was made. See below with the screen shot with marks.

I have also attached here the edit version of the screenshot. I don’t think you need this but here as you wanted to see.

There’s nothing wrong with my side at least till now since many years ago. Something was updated and errors has come up. Developer must look at this asap.


I cannot diagnose your problem with those partial screen shots

You can also look at the customers account and transactions to see how any payments made by the customer (your receipts) were allocated to their invoices

I agree it looks odd but there may be a simple explanation …

Please state which edition(Cloud, Server, Desktop) and version of manager you are using

Hi Joe,

Problem is the system counting double the gst on imports.
I always pay by invoice and allocate to each invoice not just allocate by customer/suppliers. So each transactions are allocated to each invoices so it cannot go wrong.

I am using cloud edition and version shows

See more screen shots. It’s adding balance due on top of total so basically gst on imports are doubled and showing overdue.

What do you see if you view the journal entries?

Why is the gst/GST on imports zero - is your gst tax code correctly setup?

I don’t think you have setup the tax correctly

In the Australian localisation, I think “GST on imports” is configured as “Pass-through (100%)” tax code.
See Create and use tax codes | Manager From which

Hi Chris,

Have you had any luck finding the solution to this? I am having the exact same problem.



I found out that the developer made a change and now we have options to choose tax rate like 0%, 100% and custom percentage.
Due to the updates, your previous setting became 100% tax rate (pass through).

Go to settings - tax codes - click your own ‘gst on imports’ tax and set the tax rate down to zero.

This was a bug. Fixed in the latest version (

1 Like