Forms and Currency Displays

Not sure if this has been covered before, however I would like to know two things:

  1. When in a Forms display, such as Quotes, Invoices, Reports etc. the available option on top of the screen allows you to Edit, Clone, Print, Email, Copy to…
    Can there possibly be a “SAVE” option, whereby one ould SAVE the report to your Computers Hard Drive straight from Manager…?
    I sometimes keep Manager documents on a another device source, and may want to move/keep a Form in my Drop Box? I now have to email the doc. to myself and then Save it to where ever I want… This is a bit tedious, unless I am missing a functionality of Manager I am not aware of…?

  2. Is it possible to format the Currency format to ones own Country (South Africa in my case) in the Customise options…?
    in SA we normally seperate in a 2 decimal display format and use a Full-Stop or Hyphen as the Cents seperator. I note Manager uses a Comma…?
    Example: Manager Display = R 1 650,00
    Our Fomat would be: R 1,650.00 or R 1 650-00
    This is not an urgent appeal, just a nice to have at this stage…!

Many Thanks for the Super Product in general!

  1. Print the form as a PDF, which will allow you to save it anywhere you want. You can’t save reports as files that can be opened, because they are generated by Manager from its database. Easier than emailing it to yourself.

  2. Under Settings, go to Base Currency and select the rand. Or leave the base currency blank and enter your desired Currency Prefix/Suffix. (I think this option may have disappeared in one of the updates for new businesses. But if so, and you were using Manager prior to that, the option will still be there.

Hi Tut,

On Point 2. The Currency on my Manager is set for ZAR and does have the Prefix R which is not the problem, I am referring to the seperators for cents which is defined as a Comma in Manager, and I would have preferred to have a dash (-) or Full Stop (.) as the seperator… Some people have seen the Comma as an extension of the Rand Value and not Cents for some reason…? But not a train smash from my side…!
Just would have been nice to have a Settings Config. when setting up to enable the user to define the Currency Layouts…

Many Thanks

Some other users have mentioned such problems. I believe some have tinkered with preferences, currency, etc. and “encouraged” Manager to produce output that looks the way they want. Search the forum and I think you might find something useful.

Thanks Tut,

For any Users that may have a similar problem, I went to the MANAGER - Preferences, Menu Option (Top of Screen) and selected “Date and number” format. Scrolled through the Countries to select the one that matches my criteria, in my case it was English (United Kingdom).

Great, format displays what I was looking for.

You had me going for a while, on printing to PDF from Manager Screen…! Did not have that print option, until I see you have a new Release to include this ! Thanks for the Manager Update !!!
Have downloaded this new Version and will check and use.

@Claude, I’m not a developer. I’m just a user like you. You should know, however, that the pace of improvement to Manager is very rapid. If you didn’t have the option for PDF’s, you were hundreds of updates behind. See the Release Notes at http://www.manager.io/release-notes.

The Save button just added is a further shortcut. The ability to “print” to PDF (which is the same thing) has been there since the Print feature was first created. That isn’t a feature of Manager, but rather of your operating system.

I live in the Netherlands.
Our standard date-format is dd-mm-yyyy
Our standard number-format is 1.234,56 So the full stop is the thousand separator and the comma is the decimal separator.
That’s fine for all documents and reports, but when I have to enter numbers with decimals, I have to use the comma which is not on the numeric keypad and that is a handicap/problem. What to do to be able to use the full-stop as a decimal separator when entering numbers? I think this problem counts for most of the European / Euro countries.
Thanks for your help.

@Hennie, so what you’re saying is that in your case it would be more suitable to have different decimal separator for viewing and different one for data-entry?

@lubos
That’s exactly what I am saying and what I would like to see in Manager.
The thousand separator is only for viewing and the decimal separator is for viewing and data entry as well.
It would be great if you could realize an extra preference / setting for data-entry.
I think a lot of people will appreciate this very much.

@lubos
Can you please tell us if different decimal separators for data-entry and viewing will be implemented and when we can expect this to happen. As I said it will improve productivity drastically. Thanks for a prompt reply.

This is something I have never thought about until you brought it up.

From my research, it appears that decimal separator on numerical keypad will be actually comma if your regional settings are configured that way.

For example, see here: http://superuser.com/questions/747250/dot-instead-of-comma-on-numerical-keyboard

There are many utilities which can re-bind keyboard too.

So I’m not sure about creating this inconsistency between data-entry and viewing. Some programs do it and users find it annoying. So I need to thread carefully.

@lubos
Hi Lubos,
Sometimes life can be very easy. I never thought about changing my regional settings. It is indeed a matter of just changing this setting as explained in the superuserlink and the comma has been changed in a dot as the decimal separator.
Thanks for your help and the hint. It solved my problem.