Error Starting Manager as a Service with nssm

I have the error below when I want to START manager server as a service using nssm
Installing%20Manager%20Service%20error

I have successfully installed the Manager Server Service but cannot run/start it as such.

@lubos any help please?

It’s been a while now since I posted this challenge, any help or workaround it yet?

What happens when you launch ManagerServer.exe without nssm ? Does it work?

Can you try reinstalling ManagerServer service by running nssm.exe remove ManagerServer and then installing it again?

Yes it works when I launch manager without nssm. However I want to have it run automatically, I think that’s the essence of nssm. I’ve tried re-stalling ManagerServer service, the problem still persists.

Just one thing, ManagerServer.exe must be launched under administrator account.

When you go to properties of ManagerServer service, what does it show under Log On tab? It should be launched under Local System account.

Untitled

Yes am running ManagerServer as an Administrator and it shows as Local System Account on ManagerServer Service properties. See below:
ManagerServer

What happens when you go to Services screen and start ManagerServer service manually?

Untitled

That’s the error I get when I manually want to run the ManagerServer Service.

Services_error

I have never used NSSM, but apparently error code 3 points to an incorrect working directory and/or environment path issue. Also, your NSSM executable path shows “Manager”…it’s a bit confusing… BTW, in the NSSM Service Installer Gui, did you double-check the paths under the “Application” tab…viz., “Path” & “Startup directory” while creating the Manager service?

No I did not check the paths under the “Application” tab while creating the Manager service because the service was installed in a DOS environment.

However, I can see “Path to executable” information on the General tab of the ManagerServer Service properties, as shown below:

ManagerServer2

I have managed to solve the problem by your clue @paddy. I uninstalled the service and reinstalled in the GUI of NSSM after I had directed the path to the ManagerServer. It worked and service is running now. However, I must point out that following the instructions on installing ManagerServer as a Service as shown on https://www.manager.io/server/installation/windows might not work. It will be best if the instructions on the NSSM executable file is followed. It’s much simpler.

ManagerServer_solved

But I have run into another issue, I have to import my businesses into this new ManagerServer, previously it wasn’t like that when I was running the server manually. I mean my businesses showed automatically with all the entries intact. Any help?

You are running a new installation, with a new application data folder location. So the current Manager installation does not know to look for any business data files. Transfer the businesses as described in this Guide: https://www.manager.io/guides/8890.

You can also do this by importing the files directly, without making a backup, navigating to them in the old application data folder location. But you will need to know which of the hexadecimal names apply to which business. Then, you will need to rename them in the new installation.

Yes, I’ve directed the new installation to the old application data folder location and renamed the hexadecimal names. I am running both Desktop and Server editions on the same machine and I thought it will update the records to show the same entries on both editions(since it is fetching from the same source), it was doing this earlier on. But I think that’s fine I can with it, or around it.

Thanks @Tut