English USA to English uk

Hi I have never had a problem untill I updated how do I change the date from usa to uk/New Zealand I have gone into setting and pick date format but nothing changes. I can not seem to change the language to anything else but usa
my pc is set for english New zealand

Go to Setting - Date Format and click on the date format required

Then that format should display in the field

Then click “UPDATE”

Did that and it didnt work. I also tried to go down the bottom on the right hand side and change it from English usa to something else and there was no other English countries listed

ok so i shut down and restated pc and it worked