DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

Discount In amount


#1

Hello can anybody help me on how to change discount in % to amount?


#2

Right now, discount column can accept only percentage.

If you want add on invoice fixed-amount discount. Simply add new line item and use minus amount.


#3

I have tried the minus sign but seem to always get NaN, which probably means Not A Number, in amount column ?

Any ideas.


#4

What country do you have set under date/number format under Preferences at the top? I will try to reproduce it. I think it’s something to do with that.


#5

Hi Lubos, I have set the following.

Language: Nederlands Dutch
Date and number format
Nederlands (Nederland) Dutch (Netherlands)
Voorbeelddatum − 29-4-2015
Voorbeeldgetal − 1.234.567,89


#6

@Lubos. You are rigth about date/number preferences. :smiley:

When I choose English(USA) negative amounts are possible. If I then change back to Dutch,
the amount stayes but when I change amount in invoice, the validator again gives me the NaN warning.

For expense claims it works better. I can enter a negative amount but the summary field does not update
itself, which it does when you enter a positve amount.

Hope this helpes.


#7

Thanks @lubos. Since release 15.3.4, I can enter negative amounts as discount for the Dutch date/number format.