Can't select Tax Payable in Bank Payment Account

I couldn’t work out why my Tax Payable amount was so large even though I was paying it until I went to check the payments I had made for GST through my bank expenses and noticed that all the Account Fields (for Tax Payable) were empty. This means that non of the payments I recorded of tax were recorded.
When I try and select it again and then Update, it seems to work, but when I go back in and the field is blank again.

Am I doing something wrong or is it the software?

This sounds like a software bug. Just to troll for ideas here, what operating system do you use? What version of Manager shows under About Manager? How recently have you updated Manager? Are you desktop, server, or cloud edition?

Also, can I presume from your general tone that this has worked correctly in the past? Or is this the first time you’ve remitted your GST?

I recently updated manager and had a heck of a time with things changing (mainly the way I had set things out), but this is something else. Yes I have paid GST over the past year, but I’ve just relied entirely on the GST reports to determine what I owe (not the tax payable).

I use Windows 10, the latest Manager version and the desktop edition.

This sounds like a bug to me. I have invited @lubos to have a look at your problem.

When I updated, I changed computers as well. Let me check other computer.

It does the same thing, but I also updated the Manager software on that computer just before I transferred the data over to this one.

ALL FIXED! After reinstalling the latest release again the issue is now gone. It is still misbehaving on the other computer …which I haven’t reinstalled the program over so I can confirm that it wasn’t my imagination…

The possible cause was that when I initially updated the software a week ago, I noticed that the figures had changed, so I decided to try and go back to the previous version. I uninstalled and tried to reinstall the earlier version, but it wouldn’t even open. I then reinstalled the latest version again over the top.
Going back to the older version must have caused a bug. Reinstalling the updated version a second time seemed to fix the issue.
Thanks everyone for your help.

Your supposition is almost certainly correct. Once you have called a data file with a newer version, you should never try to open it again with an older version. Not all versions of Manager change file structures, but some do because of enhancements to features. And there have been some significant changes recently.