Business Settings

I cannot seem to edit the business address at settings/business details.

On my screen it seems read only and fixed at 1313 Webfoot Walk.

Not sure what I am missing.


Have you actually tried typing in the field? The Webfoot address appears as a placeholder from the default settings when a business is created. It should appear in grey. Type in the field and what you enter should be in black. Be sure to click Update when finished.