Batch update to empty custom field values does nothing

If I do a batch update and change the custom field value to empty, it does not make the value empty.

Please provide some screenshots illustrating the problem.

Also tell us about the custom field. Is it classic or new style?

The classic custom field. Did not test for new style, they might have same issue as well.

Attached a simple test business. Please follow these steps to replicate the issue:

  1. Import the test business
  2. Go to the “Purchase Invoices” tab
  3. Click on “Batch Update” available in the bottom actions
  4. Copy & paste the data below in the text-area box:
Reference	CustomFields.651551435ccb45b085a876ef9345e572	Key
2		6a6c131b-11c0-4604-9c07-fff8281ea47d
1	Changed Name 01	96b90ed2-2a5b-4b1c-8b6f-b8f7c3b81087
  1. Click on “Next”, then click on “Batch Update”
  2. In the “Purchase Invoices” list, you will see that the entry with new value (Ref # 2) got updated, but the entry with empty value (Ref # 1) retained the original value.

test-batch-update-problem.manager (92 KB)

I suspect that you have to enter a value - if you enter nothing, then the original value is retained

Have you tried entering " " or some such value
This actually seems sensible to me

Understood, and agreed on your point that it seems sensible as it avoids value removal by mistake.

The question then becomes - How do I remove the value of a field using batch update?

I tried " ", it did not work.

What about “” ?

I can confirm this.

Also, I tried deleting the entire custom field column – which used to set the custom field to nothing for all rows and I can report that that didn’t work either.

This seems to be due to changing the behavior of batch operations from PUT to PATCH which is a requested feature. Though this is an overall improvement, I believe that the user should be able to set any field to zero in bulk.

I don’t know if @lubos has any plans for this using the new and improved Find & Recode feature or will this still be possible using Batch Operations, in any case, this should go to bugs for now.

Fixed in the latest version (23.1.2)

Thats great! The downloads page is showing the older version currently, plz push the updated build.