This feels like a maintenance function not a transaction function. Would it be possible to move it under settings similar to other maintenance tasks rather than showing as a ‘transactional tab’? My tab list is getting longer and longer!
please do not create multiple topics for the same suggestion. it only makes other users and the developer hard to follow what is being suggested. you yourself had created the below topic last month explaining the very same thing.