Reverse charge question

I see, so I need to create 2 different tax codes. 1 for the sale(Non RCM) and one of the purchase(RCM).

The sale tax code can be a custom tax code I call (Reverse Charge) but I do not tick the tick box that changes the tax into RCM. Now for the other one, the purchase, I can leave it named as RCM but need to tick the box.

Today I need to create a customer invoice(EU to EU and B2B), I will use the first box(Reverse Charge) and set it to 0%. Am I correct?

It is very confusing indeed!

Thank you,

No. If you are selling under circumstances where reverse charged VAT is appropriate, then you do not need to apply any tax code to line items on your sales invoice. Responsibility for assessing and collecting the tax has been transferred to the purchaser (who will immediately offset the tax they would normally pay to a supplier with their claim for VAT recovery on the purchase). You might be required to add a note (via a custom field) to your sales invoice indicating the sale is made under a RCM VAT scheme. But the entire point of RCM VAT is that both sides of the tax transactions are shifted to the purchaser so the foreign country does not have to collect remittances from a seller in another country, and sellers do not have to file VAT returns in foreign countries.

Except for the custom tax code necessary for RCM VAT, all others you require should be installed as localizations from See the Guide: Add localized settings and features | Manager.

Now, having said all that, there are some EU countries that specify 0% tax codes for intra-EU trade. Where such is known to be the case, those tax codes are included in the localization package.Add localized settings and features | Manager. You have not mentioned which country you are in, but the installation instructions on the Localizations web page will tell you whether any such tax code will be added when you localize.

Thanks I pmed you my country.
I downloaded the required package but I am not sure this will workas I now see 3 new taxes(I only use one of them).
The problem is that due to the V.A.T return complexity(over 40 boxes), I had to create different taxes like:
xx% sales of service
xx% sales of product
xx% purchase 0% IC
xx% Sales 0% IC
and many more.

I could not find another way to dissociate the V.A.T in the reports to help me fill in the V.A.T returns.

When the module is downloaded, it only gives you 1 standard V.A.T for both the purchase and sales.

I do not understand this statement. You first said there were three. The way VAT tax codes work is to use whichever is appropriate for the purpose. All of them post to Tax payable, where they offset one another, depending on whether the code has been applied on a sale or purchase.

Understand that Manager does not necessarily directly produce every bit of information you need for filing taxes. Sometimes you need to work to dig things out in the right categories. Intelligent design of your chart of accounts can help in this regard. The various tax reports also help separate things.

It may also be that someone will eventually create a report transformation to simplify your tax filing. So far, this has happened for a few countries, such as Australia, Netherlands, and the UK. Have a look at those countries’ localization packages to see the kinds of things that might have to be done. Often, extensive use of custom fields is necessary.

Yes the other 2 taxes are irrelevant to my type of business.
What I meant is that the localisation package does not seem to be needed because all it does is add 1 standard V.A.T tax code which can be easily added by hand.

Regarding the report transformation, could you please kindly send me a page where I can check the type of logic/code that needs to be built? I am a php/js coder, i should be able to do that.

It looks like Manager has been built with electron.

Have a look at Localisation: GST/VAT worksheet programming guide

As explained in the above reference; it enables code you generate to be also usable by all other users in your country (instead of only working with your business file).

Again as explained in the above reference, Manager reports these separately for each tax code (based on the context the tax code is used).

The interface Lubos has provided should be easy for you as it is aimed a users with less programming experience but good local accounting knowledge. Note the details are likely to change but very similar functionality is likely to be maintained.

Note the detail of reverse changed VAT may also change at some time see Tax Withholding Percentage - #26 by lubos however these changes are likely to simplify writing localisation using them.

The easiest way is to create a test business and see what happens when you add test entries (in general nothing is reported when no test data has been entered). Doing this also simplifies posting screen shots as only dummy data is shown.

You can also look at other EU countries localisation such as the UK or Netherlands for illustrations of how it is generally handled. However details of local tax laws, accounting conventions and Managers conventions are almost certainly to be the difficult part for non accountants.

Thanks for your reply and explanation. I will check the programming guide later on.

The problem with doing this is that reports only pick up transactions using the tax codes downloaded with the report. The reports are designed with knowledge of only those tax codes.

So right now I am with my wife looking at this and we are a bit confused…
I understand that you said earlier on that we see negative numbers because we have applied RCM to the sales. Ok with that.
You also suggested that we should not add any tax when it is a sale(Intra community B2B). The problem with that is, how at the end of each accounting period, would you remember(without external notes) which sales have to go into a recapitulative statement is this sale is treated like a EU to USA sale(no V.A.T). This is the part we do not get.

I also wanted to add(update) that based on the above picture, the negative numbers do not only happen when I set a sale to 0% but it happens to any sales(20%, 18%). All the purchases are in black and positive and all the sales in red and negative. I am now wondering if this is actually just normal.

Thank you.

What I tried to convey is that, from an accounting perspective, you don’t need a 0% tax code when no VAT is being assessed on a sale. But I also said later that some countries require one. When this is the case, that is for administrative purposes; it has no financial effect. Your use case also addresses an administrative purpose, but an internal one.

It is important to understand that some things are required in order to get the accounting correct. Other things may be required in order to comply with legal requirements. Still others may be useful for streamlining your personal workflow. The program does not necessarily anticipate all of those.

Yes, it is. As I said, the numbers you showed in your screen shot are all negative (and therefore red) because you incorrectly applied RCM VAT to sales transactions. If you only apply RCM VAT tax codes to purchases, you will see them as positive numbers and in black.

By doing this, you are denying other Manager users from your own country from assisting you.

Most countries use only one VAT code for “normal” purchases and sales.
Accounting wise they are collected together into the one Tax Payable account (Black & Red).
However, in the background Manager keeps a variety of separate purchase & sales totals based on the tax codes used so that they can be entered on to the various reports correctly.

Custom tax codes are limited to how they can be used compared to the in-built (downloaded) ones.

I understand totally what you mean, but this is not happening just to RCM.
I have set this one as a custom tax and not RCM.

The table still shows all the amounts as red.

My wife looked at it as well and cannot work it out.

Thank you.

I am very sorry but I prefer to stay anonymous, the country is small and as I post certain tables with amounts in them I really prefer it to be this way.

Regarding this:

Most countries use only one VAT code for “normal” purchases and sales.
Accounting wise they are collected together into the one Tax Payable account (Black & Red).
However, in the background Manager keeps a variety of separate purchase & sales totals based on the tax codes used so that they can be entered on to the various reports correctly.

Custom tax codes are limited to how they can be used compared to the in-built (downloaded) ones.

As I moved the accounts from Xero, I was trying to keep the kind of structure you see on this page(but not for UK):

When you have “Name/Tax Rate Display Name” “Tax Type” “Tax Rate”
I was expecting to have a “tax type” in manager that would show up on my side of the software but not on the invoices, receipts. I know Sage and the others do that to, not having this feature makes it very hard for us as we had to add all the tax codes in the tax name box(which shows all over the invoices/receipts). I tried custom box but it is not right either as it does not change according to the selected tax, you have to change it independently from the tax name you select.
As we need to fill in MOSS returns and recapitulative statements, it is very difficult to keep track of the various taxes without a tax type and tax type report. Tax type can help you understand with a short descript what this tax is about before adding it to the invoices/receipts. A small feature but so important.

Which is similar to the UK Manager localisation except separated codes for sales and purchases are not required as Manager tracks these separately for all it’s tax codes

In contrast the Netherlands uses more tax codes as they use multiple VAT rates for local transactions

Again, because the amounts and balances all happen to be negative. But you have not explained what your screen shot shows. I have little doubt it is correct, but if you do not tell us what it is, no one can explain why the numbers are negative. Also show a screen shot of the Edit screen for one of the transactions involved.

Any balances you see negative are sales with the normal V.A.T tax rate(No RCM).
I just clicked on one of the sales for you to see:

The example you show me here is exactly the problem I am having.
In your custom tax you have for example:
“VAT 20% on imports”

Why this shows on the invoice rather than:
“VAT 20%”

It would have been great to have a new box in with:

TAX | DESCRIPTION(does not show on paper)
VAT 20% | on imports

@benoit, you did not provide the most important information I requested: a description of what you screen shot shows. I reiterate that no help is possible until you describe what you are showing. And you must show the entire Edit screen so we can see all details of the transaction. Obscure only proprietary information.

Also, do I correctly interpret that you have created a line-item custom field called “Reverse Charge?” If so, why? What do you hope this will accomplish? How will you use it?

Sorry about that, let me restart from fresh screenshot by screenshot.

Number 1:
When Click on this button:

I end up here. When I click on the 16 transactions on this line(which are sale invoices).

I see this:

As you can see all the transactions in this table have the same tax(which is not RCM) and they are either sales invoices or receipts.

Now Let’s look at the tax that I have chosen on this table(the one pointing top the red arrow).
As you can see in the below image, nowhere it shows the tax as RCM. The “tax type” custom field is just me messing around as I was trying to hide the data between parenthesis in the Name but it won’t work as I won’t see it on the reports.

Also here is an example of one of the sales invoice so you see how it is entered(below it becomes negative in the above table), the invoice 11119:

So, now I have given all the information, let me reply to your questions about:
Also, do I correctly interpret that you have created a line-item custom field called “Reverse Charge?” If so, why? What do you hope this will accomplish? How will you use it?

The reason I did that is because in the country where I live, the word “Reverse charge” most show in the invoice. I could not find a better way of doing it sorry. All I do is enable that box and write “Reverse charge” inside it.

The second question is:
We understand 100% your explanations of the transactions being negative when RCM is added to the customs tax and the tax used on Sales(we understand this perfectly now). But in the above examples, the tax is not RCM(customer, single rate, 18%) but still output all our sales as negative in the custom tax table. Unless both my wife and I missed something, we cannot understand the logic behind this sorry. And my apology if there is something very big we have missed or misunderstood in your previous explanations. We tried to show this to some of our friends but none of us understands it.

Thank you.

Thank you for the complete information. I have several responses:

  • The amounts in the drill-down on the number of tax code transactions are negative because they are credits. Manager’s convention is that debits are positive and credits are negative. (This is a choice made by the designer of the software. It could have been the other way around.) If you drill down on Tax payable in the Summary, you will see the related tax amounts as positive numbers. That is a matter of how they are displayed. As with many aspects of accounting, there is the underlying math, and then there are the conventions about how things are displayed. For example, both income and expenses are frequently shown as positive numbers to reduce clutter. Context is important.
  • In the future, there are easier and more intuitive places to see tax amounts and balances than going back into the Settings tab.
  • I do not recommend using custom tax codes in your situation. Use those available from localizations. These will be easier to update in the future, and they will used in future report transformations for your country.
  • I would recommend putting your statutory RCM notation in a notes custom field rather than a line-item custom field. As I understand it, that requirement will always apply to an entire invoice, not a single line item. And that way, you won’t see the column on domestic transaction forms.