Possible import backup file bug

Possible import backup file bug. Ubuntu, Manager Server 16.10.55 Backup import error.

Carry out backup in Manager version 16.10.38. Attempt to import the backup file into Manager Version 16.10.55 and the above error occurs.
Tried multiple backup files same result. Test same backup file restore and import OK to Manager Version 16.10.38.

How big is the backup file?


1.3 Mb shouldn’t be a problem. Is this happening with any backup file? How about you make a backup of empty business and import that. Does it work?

I have imported three another company backup files OK and successfully from ver 16.10.38 to ver 16.10.55. They are smaller 91.5kB, 117.6kB and 381.5kB.

Bear in mind all backup files restore seamlessly back into Ver 16.10.38 even the 1.3Mb one.

Another test carried out was to import a backup file from a month back … Size 1.2Mb and it also failed with above error. Going further back to a July 2016 backup file size 885kB for same entity and that restores OK to Version 16.10.55.

I think the issue is backup file size related because the moment the imported file exceeds 1Mb it fails with the error above. I tested a 1Mb file of the failing entity and it imported OK. A slightly larger backup file of the same entity 1.1Mb failed including all above 1Mb in size.

Ubuntu Server Manager Ver 16.10.56 gives the same import issue. Is there anyone else having this problem or is it unique to the setup I have?

Problem solved - It is not a Manager problem - This issue was a Nginx client configuration issue /limit. The client_max_body_size directive assigns the maximum accepted body size of client request, indicated by the line Content-Length in the header of request. If import file size is greater than the one specified in the nginx.conf file or if it is not specified, then the client gets the error “Request Entity Too Large” (413). To fix this issue edit your nginx.conf.

    sudo nano /etc/nginx/nginx.conf

add the following in the http section

    # set client body size to 10M #
    client_max_body_size 10M;

Save the nginix config file, then restart the nginx service to reload the new config

    sudo service nginx reload

Help found on this page http://www.cyberciti.biz/faq/linux-unix-bsd-nginx-413-request-entity-too-large/
by Vivek Gite