DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

PDF problems with custom themes?


#1

I have just updated my desktop version (tonight) to 19.1.41 for Mac, and PDF seams to be having a hard time with custom themes as soon as I did so. Yep, I should have kept both versions on my Mac but I didn’t. For some reason, the cloud version doesn’t have a problem with the same theme and works fine.

inbuilt themes are working, but the custom themes have vital information coded in and looks really nice.

Desktop version is where I build and test themes before putting them in use.
msg I am getting:

#=z4HxPolTRqX83BpEYpaykwEU85Sv8GhtjEVYPWPg=: #=z4HxPolTRqX83BpEYpaykwEU85Sv8GhtjEVYPWPg=: The required table ‘head’ was not found.

at #=zlnQpeIyQpvereRcz5LVbwO4isBvJIu0Dvw==.#=zKwnEupY= (System.String #=z7VvCEauWRKQG, #=zCfP6lcNLLwLdmyKvlYaJYi1pOcIoQ2tprw== #=zBSQLrjc=, #=zENDUCA6KF$FmU4C3QpQhGkuggURaTTZz2pDzlcE= #=zN3hljxJepivV, System.Boolean #=zN4bNBag=) [0x0007e] in <6b3362386b9440a166fdc0086db699fc>:0

at #=zlnQpeIyQpvereRcz5LVbwO4isBvJIu0Dvw==.#=znLSOrtyJZWPp (System.String #=z7VvCEauWRKQG, #=zCfP6lcNLLwLdmyKvlYaJYi1pOcIoQ2tprw== #=zBSQLrjc=, #=zENDUCA6KF$FmU4C3QpQhGkuggURaTTZz2pDzlcE= #=zN3hljxJepivV) [0x00000] in <6b3362386b9440a166fdc0086db699fc>:0

at #=zlnQpeIyQpvereRcz5LVbwO4isBvJIu0Dvw==.#=z1mEuVVUQ5rpe () [0x004a9] in <6b3362386b9440a166fdc0086db699fc>:0

at #=zlnQpeIyQpvereRcz5LVbwO4isBvJIu0Dvw==.#=zmAT7Oik= (#=zmo3xjgBnQKRyIUfqFPjzpthckMK1JN8qtw== #=z28M4eAu$LCC1) [0x00037] in <6b3362386b9440a166fdc0086db699fc>:0

at #=zsiRoY_3xqrJl53jj0bCXHzFyKbht.#=zEYU8gLg= (#=zmo3xjgBnQKRyIUfqFPjzpthckMK1JN8qtw== #=z28M4eAu$LCC1) [0x00046] in <6b3362386b9440a166fdc0086db699fc>:0

at #=zyH4pM8qcQSd7ViPKjD06hE$k0yxyTF4ZPw==+#=z$FnvRaKSz2XLrVC1Sc9wtBY=.MoveNext () [0x000c1] in <6b3362386b9440a166fdc0086db699fc>:0

at Apitron.PDF.Kit.FixedLayout.Resources.Fonts.Font.#=zmqQhu1OranhIfMAnkPAbFBE= (System.String #=z28M4eAu$LCC1, System.Int32 #=zUELD_yQ=, System.Char #=zKS_JwDmzbYnU4mBYQQ==) [0x0035d] in <6b3362386b9440a166fdc0086db699fc>:0

at Apitron.PDF.Kit.FixedLayout.Resources.Fonts.Font…ctor (System.String resourceID, System.String fontDefinition, System.Int32 fontIndex) [0x0000f] in <6b3362386b9440a166fdc0086db699fc>:0

at #=zcl6DiKLvmrKZdr_ZqydUq0lUaPcWPE7zGR_aBPQ=.#=zPNYCAzE= (#=zv6voIMZ2C9NkqJ_zX2pkvbkYEHTsDe9UHsLfyy0= #=zzEN3jPE=) [0x0008e] in <6b3362386b9440a166fdc0086db699fc>:0

at #=z35057D1o_fsG5jp_VbvM3$YhmrCKzzTmnknCBKdq8SwN…ctor (System.String #=zyDXJn0Y=, #=zcl6DiKLvmrKZdr_ZqydUq0lUaPcWPE7zGR_aBPQ= #=zm4ddAKijlYRK, System.String #=zaJAceJJPwrWj, System.Double #=z1u7B3aIg3TNd, System.Double #=znU4MctoQfn4$, System.Double #=zDldzPuA=, System.Double #=zoKmit$or4ii7, System.Boolean #=zquqwqvyoIEaR) [0x000be] in =z4HxPolTRqX83BpEYpaykwEU85Sv8GhtjEVYPWPg=: #=z4HxPolTRqX83BpEYpaykwEU85Sv8GhtjEVYPWPg=: The required table ‘head’ was not found.

at #=zlnQpeIyQpvereRcz5LVbwO4isBvJIu0Dvw==.#=zKwnEupY= (System.String #=z7VvCEauWRKQG, #=zCfP6lcNLLwLdmyKvlYaJYi1pOcIoQ2tprw== #=zBSQLrjc=, #=zENDUCA6KF$FmU4C3QpQhGkuggURaTTZz2pDzlcE= #=zN3hljxJepivV, System.Boolean #=zN4bNBag=) [0x0007e] in <6b3362386b9440a166fdc0086db699fc>:0

at #=zlnQpeIyQpvereRcz5LVbwO4isBvJIu0Dvw==.#=znLSOrtyJZWPp (System.String #=z7VvCEauWRKQG, #=zCfP6lcNLLwLdmyKvlYaJYi1pOcIoQ2tprw== #=zBSQLrjc=, #=zENDUCA6KF$FmU4C3QpQhGkuggURaTTZz2pDzlcE= #=zN3hljxJepivV) [0x00000] in <6b3362386b9440a166fdc0086db699fc>:0

at #=zlnQpeIyQpvereRcz5LVbwO4isBvJIu0Dvw==.#=z1mEuVVUQ5rpe () [0x004a9] in <6b3362386b9440a166fdc0086db699fc>:0

at #=zlnQpeIyQpvereRcz5LVbwO4isBvJIu0Dvw==.#=zmAT7Oik= (#=zmo3xjgBnQKRyIUfqFPjzpthckMK1JN8qtw== #=z28M4eAu$LCC1) [0x00037] in <6b3362386b9440a166fdc0086db699fc>:0

at #=zsiRoY_3xqrJl53jj0bCXHzFyKbht.#=zEYU8gLg= (#=zmo3xjgBnQKRyIUfqFPjzpthckMK1JN8qtw== #=z28M4eAu$LCC1) [0x00046] in <6b3362386b9440a166fdc0086db699fc>:0

at #=zyH4pM8qcQSd7ViPKjD06hE$k0yxyTF4ZPw==+#=z$FnvRaKSz2XLrVC1Sc9wtBY=.MoveNext () [0x000c1] in <6b3362386b9440a166fdc0086db699fc>:0

at Apitron.PDF.Kit.FixedLayout.Resources.Fonts.Font.#=zmqQhu1OranhIfMAnkPAbFBE= (System.String #=z28M4eAu$LCC1, System.Int32 #=zUELD_yQ=, System.Char #=zKS_JwDmzbYnU4mBYQQ==) [0x0035d] in <6b3362386b9440a166fdc0086db699fc>:0

at Apitron.PDF.Kit.FixedLayout.Resources.Fonts.Font…ctor (System.String resourceID, System.String fontDefinition, System.Int32 fontIndex) [0x0000f] in <6b3362386b9440a166fdc0086db699fc>:0

at #=zcl6DiKLvmrKZdr_ZqydUq0lUaPcWPE7zGR_aBPQ=.#=zPNYCAzE= (#=zv6voIMZ2C9NkqJ_zX2pkvbkYEHTsDe9UHsLfyy0= #=zzEN3jPE=) [0x0008e] in <6b3362386b9440a166fdc0086db699fc>:0

at #=z35057D1o_fsG5jp_VbvM3$YhmrCKzzTmnknCBKdq8SwN…ctor (System.String #=zyDXJn0Y=, #=zcl6DiKLvmrKZdr_ZqydUq0lUaPcWPE7zGR_aBPQ= #=zm4ddAKijlYRK, System.String #=zaJAceJJPwrWj, System.Double #=z1u7B3aIg3TNd, System.Double #=znU4MctoQfn4$, System.Double #=zDldzPuA=, System.Double #=zoKmit$or4ii7, System.Boolean #=zquqwqvyoIEaR) [0x000be] in


#2

The desktop and cloud editions are exactly the same except for multiple users being allowed on the cloud edition.

You are responsible for troubleshooting your own custom themes. In a generic sense, I just tested PDFs with a custom theme in version 19.1.41, and there was no problem. So this looks like an issue with your code. (Understand, it is entirely possible that something you got away with on a custom theme in a previous version no longer works on a newer version. But the fact that your theme works with the cloud edition strongly suggests a computer issue, not a Manager issue.)

Reading your error message, there are a lot of things listed pertaining to fonts. Be aware that Manager does not support all font attributes, and there may be issues between how PDFs are rendered via your browser versus on the desktop edition. I would start troubleshooting by systematically eliminating your “sportier” font attributes one at a time to see if you can identify whether one causes the problem.


#3

I did mention above that the inbuilt themes do work in pdf.

I don’t add any code relating to font. it is purely layout, colour and information.

I copied and pasted the theme from cloud that is working fine with pdf… and pasted it to desktop version, that makes it hard for troubleshooting the code, because the code does work. There is nothing wrong nor experimental with my code, only adding legal Health Dept. requirements and banking details for my clients then formatting the layout so it is readable (and so clients don’t play with it like they can with a custom field - yes that is known to happen too).

I will back up my manager accounts, completely remove manager and reinstall to see if that helps, it may be an installation issue as the same pdf was rendering properly on desktop just minutes before I updated.


#4

We are having problems with PDF today too. Cloud edition. Press the PDF button and it does nothing. For some reason it seems to be only a certain customer, but haven’t tried all customers. The PDF button is working with other customers. We only have one theme so it’s the same theme. @lubos can you please look into this? Thank you.


#5

Also tried on 2 computers and chrome and internet explorer, still happening.


#6

I think these are two unrelated issues. @sparky, can you email me details to lubos@manager.io and I will look into this.


#7

Thank you. It’s now fixed.